Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6084 - bash "set -o vi" command-line editing doesn't work
Summary: bash "set -o vi" command-line editing doesn't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 6510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 14:58 UTC by bjn
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-01 20:27:13 UTC


Attachments (Terms of Use)

Description bjn 1999-10-19 14:58:36 UTC
I use RedHat 5.2 and 6.1; the bash packages are the same
version but different build numbers.  I have compared the
"set -o" output on both systems, and they're identical; they
include "vi on" to enable vi command-line editing mode.

However, pressing escape plus any key just beeps under 6.1,
both from the console and from a terminal in X; this mode
doesn't appear to work at all in this version.  Please
advise if there's a work-around or source patch, and I'll
rebuild from the SRPM.

Thank you!

Comment 1 depub1 1999-11-03 19:25:59 UTC
set -o vi works if manually typed in AND NOT in .bashrc
If in .bashrc (like everyone does) it wont respond to set -o vi
manually nor will it take the setting from the rc

------- Email From  "Brent J. Nordquist" <bjn@visi.com> 12/08/99 14:50 -------
Attached to Bug # 6084.

Comment 2 Cristian Gafton 2000-02-01 20:27:59 UTC
*** Bug 6510 has been marked as a duplicate of this bug. ***alternatively, take out the meta stuff from /etc/inputrc

set -o vi and meta input conflict in bash 1.14.7


Note You need to log in before you can comment on or make changes to this bug.