Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6083 - password lock/unlock option working incorrectly !
Summary: password lock/unlock option working incorrectly !
Keywords:
Status: CLOSED DUPLICATE of bug 5449
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 08:57 UTC by dll
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 20:18:54 UTC


Attachments (Terms of Use)

Description dll 1999-10-19 08:57:31 UTC
passwd command works incorrectly when using -l and -u
options.
-u option do not recover hash properly and cause
impossibility for the
target user to log in. Example:

iser test.
his hash from /etc/shadow is CodMKO/mkdJ2I
now root enters #passwd -l test
now in /etc/shadow tests's hash is !CodMKO/mkdJ2I
That's ok. Now trying #passwd -u test
passwd writes Success. Opening /etc/shadow and tests's hash
is:
CodMKO/mkdJ2I~E^U@^P
... ;-(
now user test will never be able to log in.... and root
should munaully
edit /etc/shadow to correct the problem.

Thanks, Dmitri

Comment 1 maavl 1999-11-23 13:32:59 UTC
This bug duplicates bug #5449.

Comment 2 Bill Nottingham 2000-02-05 20:18:59 UTC
*** This bug has been marked as a duplicate of 5449 ***


Note You need to log in before you can comment on or make changes to this bug.