Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6077 - problems with too long strings in ftp
Summary: problems with too long strings in ftp
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 05:52 UTC by joachim.buchert
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-19 05:52:55 UTC


Attachments (Terms of Use)

Description joachim.buchert 1999-10-19 05:52:55 UTC
In an ftp session to transfer data between Linux servers
the system does not allow me to enter strings longer than
about 200 bytes. Please see a constructed example below.
The system responds with the message
sorry, input line too long
The ftp session is included in a complex program and the
error occurs because sometimes the files to be copied are
very deep in the file system hierarchy which makes longer
strings unavoidable. I could think of workarounds by making
the file names shorter. But this would cause a lot of work.
By the way, other UNIX products (i.e. HP-UX) do not have
this problem.
EXAMPLE:
[root@twdfr112 ~]# ftp twdfr112
Connected to twdfr112.wdf.sap-ag.de.
220 twdfr112.wdf.sap-ag.de FTP server (Version wu-2.4.2-VR17
(1) Mon Apr 19 09:21:53 EDT 1999) ready.
Name (twdfr112:root): root
331 Password required for root.
Password:
230 User root logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd /tmp
250 CWD command successful.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 11896
drwxrwxrwt   9 root     root         4096 Oct 19 04:02 .
drwxr-xr-x  23 root     dba          4096 Oct 14 13:43 ..
drwxr-xr-x   2 root     root         4096 Oct 15 15:48
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaa
226 Transfer complete.
ftp> cd
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaa
sorry, input line too long

Comment 1 Pekka Savola 2000-07-14 09:24:50 UTC
Call this a security feature, not a bug.



Note You need to log in before you can comment on or make changes to this bug.