Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6076 - named doesn't start at any runlevel
Summary: named doesn't start at any runlevel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 6114 6671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 05:49 UTC by tom
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-19 14:47:09 UTC


Attachments (Terms of Use)

Description tom 1999-10-19 05:49:24 UTC
Just did a fresh install of RH6.1 on a system.  Named didn't
start automatically, so I started looking around.  In all
rcx.d directories, it was K45named.  Under a RH6.0 install I
did on another system, it was S55named in rc3.d, rc4.d and
rc5.d.

I renamed the files to match my RH6.0 install, and all looks
good

Comment 1 Bill Nottingham 1999-10-19 14:47:59 UTC
It's a change in policy. You can use ntsysv, or
chkconfig --level 345 named on
to turn it on.

Comment 2 Bill Nottingham 1999-10-20 04:14:59 UTC
*** Bug 6114 has been marked as a duplicate of this bug. ***

When upgrading from RH 6.0 to RH 6.1...
The next thing I noticed is that my DNS (named) was no
longer running.  To fix this rename the "K45named" file in
rc3.d, rc4.d, and rc5.d to "S55named".  And then issue the
following command:

/etc/rc.d/init.d/named start

Comment 3 Bill Nottingham 1999-11-03 17:07:59 UTC
*** Bug 6671 has been marked as a duplicate of this bug. ***

NFS start moved to init 4 from init 3 in RH 5.2

Why all these policy changes? named doesn't even start in
RH6.1 unless manual tweaking is done! Yuk!


Note You need to log in before you can comment on or make changes to this bug.