Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6072 - vi terminates with extra 'c'
Summary: vi terminates with extra 'c'
Keywords:
Status: CLOSED DUPLICATE of bug 7043
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-18 23:37 UTC by len
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-29 17:06:22 UTC


Attachments (Terms of Use)

Description len 1999-10-18 23:37:14 UTC
When I use vi (minimal version or vim), after quitting,
there is an extraneous 'c' before the prompt in the
terminal window.  This happens if I just quit without
having entered any text.   If I start vi and then use
Ctrl-z and kill the job, there is no 'c'.

Comment 1 Jeff Johnson 1999-10-19 16:35:59 UTC
FWIW I can't reproduce this problem on sparc or i386.

What type of terminal window?
What termcap entry are you using?
How are you quitting /bin/vi?
What shell? Are you overriding the prompt in any unusal way?


------- Additional Comments From   10/19/99 14:58 -------
I see the same bug Terminal window -- gnome-terminal only -- does not
happen with xterm
quit /bin/vi with :wq or :q
/bin/bash
prompt overriding with PS1="bash@\h\\$ "

Comment 2 Michael K. Johnson 1999-11-18 18:49:59 UTC
I have reproduced this bug in gnome-terminal.

Comment 3 Havoc Pennington 1999-11-29 17:06:59 UTC
*** This bug has been marked as a duplicate of 7043 ***


Note You need to log in before you can comment on or make changes to this bug.