Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6069 - linuxconf/ifup-aliases do not work together
Summary: linuxconf/ifup-aliases do not work together
Keywords:
Status: CLOSED DUPLICATE of bug 5784
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-18 21:05 UTC by bgraw3
Modified: 2014-03-17 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-18 21:10:06 UTC


Attachments (Terms of Use)

Description bgraw3 1999-10-18 21:05:55 UTC
If you use linuxconf/config/networking/server tasks/IP
aliases for virutal hosts the virtual hosts do not work.
linuxconf makes some files in
/etc/sysconfig/network-scripts like ifcfg-eth0:? and if you
try and run ifup-aliases you get errors like the following:

ipseen_130_37_129_65-74=ifcfg-eth0:0: command not found
ifup-aliases: error in ifcfg-eth0:0: already seen ipaddr\
   130.37.129.65-74 in -74

The ifup-aliases script has some documentation regarding
IPADDR_START, IPADDR_END, but the files created by linuxconf
don't seem to follow this and use IPADDR.

If you undo some of the debugging comments in ifup-aliases,
the device (in the script as $DEVICE) does not appear to be
defined correctly. But, if you change it to $device, other
parts seem not to work.

Comment 1 Bill Nottingham 1999-10-18 21:10:59 UTC
*** This bug has been marked as a duplicate of 5784 ***


Note You need to log in before you can comment on or make changes to this bug.