Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6035 - mailertable should be in /etc/mail
Summary: mailertable should be in /etc/mail
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-18 06:52 UTC by Kolar, Petr
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-17 14:16:58 UTC


Attachments (Terms of Use)

Description Kolar, Petr 1999-10-18 06:52:33 UTC
/etc/rc.d/init.d/sendmail expects mailertable to be in
/etc/mail directory. But FEATURE(`mailertable') causes
sendmail will search it in /etc.

Fix: replace FEATURE(`mailertable') line in
/usr/lib/sendmail-cf/cf/redhat.mc for line
FEATURE(`mailertable', `hash -o /etc/mail/mailertable')

Comment 1 Giuseppe Paterno 1999-12-08 10:01:59 UTC
Another way to fix the problem is to insert in the source m4 file
define(`_USE_ETC_MAIL_').

Default behaviour for feature/mailertable.m4 is to use /etc/mailertable if the
above define is not set.

------8<----- CUT HERE -----8<------
define(`MAILER_TABLE', ifelse(_ARG_, `',
                              ifdef(`_USE_ETC_MAIL_',
                                   DATABASE_MAP_TYPE` -o /etc/mail/mailertable',
                                   DATABASE_MAP_TYPE` -o /etc/mailertable'),
                              `_ARG_'))dnl
------8<----- CUT HERE -----8<------

Hope this helps.

Comment 2 Bernhard Rosenkraenzer 2000-02-17 14:16:59 UTC
Thanks, fixed in 8.9.3-19.
define(`_USE_ETC_MAIL_') is not exactly the same, by the way. That would also
relocate some other files (/usr/lib/sendmail.hf)


Note You need to log in before you can comment on or make changes to this bug.