Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6024 - /tmp/hdimage not unmounted if not enough free space during install
Summary: /tmp/hdimage not unmounted if not enough free space during install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-17 22:43 UTC by tawood
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-22 19:34:09 UTC


Attachments (Terms of Use)

Description tawood 1999-10-17 22:43:09 UTC
When installing from a local disk a python scripting error
occurs on a second install attempt if the first install
attempt failed because of a lack of free disk space.

Scenario:

1. Select Packages to install
2. Install Screen determines you need an additional XX MB of
space to proceed.
3. Press <Back> to uncheck some more packages which are not
required
4. Select install and an error occurs because the device is
in use.

Python scripting error and you can select to drop in debug.

---

Work around is to flip to F2 console and manually unmount
the /tmp/hdimage after the installer determined there was
not enough free space to install.

I guess the fix would be to unmount the local disk partition
when it is determined there is not enough space to install.
This should be okay since the only option at this point is
to press <Back>... There are other temporary mounts which
are unmounted automatically... just not the /tmp/hdimage.

The manual unmount worked successful.

If the error occurs... the installer automatically reboots
the machine after shutting everything down.

Comment 1 Jay Turner 1999-10-22 19:34:59 UTC
*** This bug has been marked as a duplicate of 5809 ***


Note You need to log in before you can comment on or make changes to this bug.