Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6018 - WindowMaker dumps on save session or exit
Summary: WindowMaker dumps on save session or exit
Keywords:
Status: CLOSED DUPLICATE of bug 8454
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-17 03:13 UTC by randolph
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-04 02:40:05 UTC


Attachments (Terms of Use)

Description randolph 1999-10-17 03:13:44 UTC
The following patch apparently didn't make it into the
release:

     * Date: Mon, 27 Sep 1999 12:38:20 -0400 (EDT)
     * From: Justin Whitney <[24]ripple@WPI.EDU>
     * To: [25]David.Bellot@loria.fr
     * Subject: Re: WMaker crash on exit.

> Every time I want to restart, save my session or exit
Wmaker 0.61 (which
> I've just compiled), I've got a crash and a core file. And
I cannot exit
> properly and save my session.

I patched this on 9.25.99.  see attatched diff.

ripple
--- WindowMaker-0.61.0/src/event.c      Sat Sep 18 22:35:55
1999
+++ WindowMaker-0.61.0.ripple/src/event.c       Sat Sep 25
04:15:50 1999
@@ -1000,7 +1000,7 @@
             event->xcrossing.y_root >= (scr->scr_height -
2)) {

 #ifdef DEBUG
-            debug_puts("pointer at screen edge in
EnterNotify event, fear");
+            dbputs("pointer at screen edge in EnterNotify
event, fear");
 #endif

            menu = wMenuUnderPointer(scr);
--- WindowMaker-0.61.0/src/session.c    Fri Sep 17 19:35:24
1999
+++ WindowMaker-0.61.0.ripple/src/session.c     Sat Sep 25
04:41:44 1999
@@ -293,6 +293,8 @@

     list = PLMakeArrayFromElements(NULL);

+    wapp_list = WMCreateBag(16);
+
     while (wwin) {
         WApplication
*wapp=wApplicationOf(wwin->main_window);
     * References:
          + [26]WMaker crash on exit.
               o From: David.Bellot@loria.fr

Comment 1 Cristian Gafton 2000-02-04 02:40:59 UTC
*** This bug has been marked as a duplicate of 8454 ***


Note You need to log in before you can comment on or make changes to this bug.