Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 599003 - tests timeout in beaker
Summary: tests timeout in beaker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah
Version: 0.5
Hardware: All
OS: Linux
high
high vote
Target Milestone: ---
Assignee: Marian Csontos
QA Contact:
URL:
Whiteboard:
: 584850 (view as bug list)
Depends On:
Blocks: 593663 603908
TreeView+ depends on / blocked
 
Reported: 2010-06-02 14:05 UTC by Karel Volný
Modified: 2010-07-27 20:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 17:31:16 UTC


Attachments (Terms of Use)

Description Karel Volný 2010-06-02 14:05:41 UTC
Description of problem:
see https://beaker.engineering.redhat.com/jobs/984
https://beaker.engineering.redhat.com/logs/2010/84/984/1873/13770///TESTOUT.log
https://beaker.engineering.redhat.com/logs/2010/84/984/1873/13771///TESTOUT.log

the tests work without any problem in RHTS


Version-Release number of selected component (if applicable):
Version - 0.5.40 

How reproducible:
the issue reappeared in https://beaker.engineering.redhat.com/jobs/1328

Steps to Reproduce:
1. run daemons tier1 testsuite on beaker
  
Actual results:
the tests
/CoreOS/mysql/bz241688-drop-privilege-rename
/CoreOS/mysql/bz232603-null-pointer-deference-crash
time out

Expected results:
all tests pass

Additional info:
I have no clue why it timed out in Beaker, there are not enough logs

please take your crystall ball and explain/fix

Comment 1 Bill Peck 2010-06-02 14:49:02 UTC
Marian,

Could this be related to the pty ?  I'm hoping the messages file which has some sysrq calls to show processes will be helpful.

Comment 2 Bill Peck 2010-06-02 18:43:44 UTC
Marian,

it appears to be getting stuck when running ausearch with the datetime format.  If I kill that process it moves on.

ausearch is just being called via commands.getstatusoutput()

Comment 3 Marian Csontos 2010-06-08 20:53:47 UTC
Re comment 1: yes, in a way it is. gdb says it's waiting for stdin pipe X-|

Could be sorted by closing input pipe (or PTYfying the RHTS wrapper) or by adding --input-logs to ausearch.

Veryfing the fix.

Comment 4 Eduard Benes 2010-06-15 16:01:22 UTC
Adding set of failing tests from job:
  https://beaker.engineering.redhat.com/jobs/2410

/CoreOS/audit/Sanity/audit-rules-smoke 
/CoreOS/audit/Sanity/auditctl-smoke
/CoreOS/audit/Sanity/aureport-smoke 
/CoreOS/audit/Sanity/audit-updates-rhel53
/CoreOS/audit/bugzilla/bug438844
/CoreOS/fipscheck/sanity

Comment 5 Marian Csontos 2010-06-21 11:36:45 UTC
Fixed upstream.

Comment 6 Bill Peck 2010-07-01 12:59:39 UTC
ping - Can this be closed?

Comment 7 Ales Zelinka 2010-07-07 17:19:20 UTC
I've scheduled tests from c#0 & c#4: all finished without time-outing:

https://beaker.engineering.redhat.com/jobs/6582
https://beaker.engineering.redhat.com/jobs/6583

Comment 8 Marian Csontos 2010-07-27 20:52:39 UTC
*** Bug 584850 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.