Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598930 - Upgrade will fail due to dirty install label issue
Summary: Upgrade will fail due to dirty install label issue
Keywords:
Status: CLOSED DUPLICATE of bug 597156
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node
Version: 5.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Alan Pevec
QA Contact:
URL:
Whiteboard:
: 598932 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 11:07 UTC by XinSun
Modified: 2010-11-09 12:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 17:49:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XinSun 2010-06-02 11:07:23 UTC
Description of problem:
I meet rhevh uggrade fail after doing dirty install.  

Version-Release number of selected component (if applicable):
rhev-hypervisor-5.5-2.2.3

How reproducible:
Always

Steps to Reproduce::
1.Make sure you have installed rhevh into FC (multipath:/dev/sdv)
2.Do dirty install into USB storage  without uninstall (USB: /dev/sdap)
3.After USB installation, register to rhevm, do upgrading. Then you can see this upgrade will fail.

check label, it will symlink to FC /dev/sdv, not usb
[root@amd-1352-8-4 ~]# ll /dev/disk/by-label
total 0
lrwxrwxrwx 1 root root 10 Jun  2 07:44 BOOT -> ../../sdv

[root@amd-1352-8-4 ~]# multipath -ll -v2 | grep sdv -A4 -C4
3600a0b80005adb0b000045794b95a91c dm-5 IBM,1726-4xx  FAStT
[size=55G][features=1 queue_if_no_path][hwhandler=1 rdac][rw]
\_ round-robin 0 [prio=200][active]
 \_ 0:0:3:0 sdl  8:176  [active][ready]
 \_ 3:0:2:0 sdv  65:80  [active][ready]
\_ round-robin 0 [prio=0][enabled]
 \_ 3:0:3:0 sdaf 65:240 [active][ghost]
 \_ 0:0:1:0 sdb  8:16   [active][ghost]
SATA_WDC_WD2502ABYS-_WD-WCAT19593718 dm-20 ATA,WDC WD2502ABYS-1

[root@amd-1352-8-4 ~]# e2label /dev/sdv1
BOOT
[root@amd-1352-8-4 ~]# e2label /dev/sdap1
BOOT
  
Actual results:
Upgrade will fail , and you can see label is symlink to FC, not the USB

Expected results:
Upgrade will success, and label is symlink to USB


Additional info:

Comment 1 Alan Pevec 2010-06-02 11:15:20 UTC
*** Bug 598932 has been marked as a duplicate of this bug. ***

Comment 3 Alan Pevec 2010-07-02 17:49:06 UTC

*** This bug has been marked as a duplicate of bug 597156 ***


Note You need to log in before you can comment on or make changes to this bug.