Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598919 - Remove kmod-spice-usb-redirector from rhel-5.5/32 will cause error message
Summary: Remove kmod-spice-usb-redirector from rhel-5.5/32 will cause error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spice-usb-redirector
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 10:47 UTC by Lei Wang
Modified: 2011-06-15 14:42 UTC (History)
6 users (show)

Fixed In Version: kspiceusb-kmod-4.5-8.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-13 23:47:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0122 normal SHIPPED_LIVE spice-usb-share and kspiceusb-kmod bug fix update (was spice-usb-redirector) 2011-01-12 17:28:42 UTC

Description Lei Wang 2010-06-02 10:47:32 UTC
Description of problem:
The default kernel in rhel-5.5-client/32 is PAE kernel and there's no kmod-spice-usb-redirector for PAE kernel, so we need yum install common kernel in order to install kmod-spice-usb-redirector, after that when we try to remove kmod-spice-usb-redirector, there appears an error message.

Version-Release number of selected component (if applicable):
kmod-spice-usb-redirector-4.5-2.el5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.Install common kernel to rhel-5.5-client os:
# yum install kernel.i686
2.Reboot, select the common kernel at grub
3.Install kmod-spice-usb-redirector and all dependent packages
4.Remove kmod-spice-usb-redirector:
# rpm -e kmod-spice-usb-redirector
  
Actual results:
An error message appears:
FATAL: Could not open '/boot/System.map-2.6.18-194.el5': No such file or directory

Expected results:
No error message appears

Additional info:
# uname -a
Linux dhcp-66-70-192.nay.redhat.com 2.6.18-194.3.1.el5 #1 SMP Sun May 2 04:22:18 EDT 2010 i686 i686 i386 GNU/Linux  
# ll /boot/System.map-2.6.18-194.*
-rw-r--r-- 1 root root 967664 May  2 16:37 /boot/System.map-2.6.18-194.3.1.el5
-rw-r--r-- 1 root root 965159 Mar 17 10:05 /boot/System.map-2.6.18-194.el5PAE

Comment 3 Uri Lublin 2010-09-28 19:02:18 UTC
I think this also true for 64 bit OS.

Note that the kernel has been updated (2.6.18-194.3.1.el5 vs 2.6.18-194).

The problem is in the %postun section.
Fix is to make it similar to the %post section, which is:
only call depmod if "/boot/System.map-${verrel}${variant}" exists.

Fix is in kmodtool (which is basically a change to the spec-file).

Comment 5 Jon Masters 2010-10-08 11:32:26 UTC
Let me know if you need anything from me.

Comment 9 Lubos Kocman 2010-11-02 16:44:52 UTC
Verified on kspiceusb-kmod-4.5-8.el5
 
rpm -e spice-usb-share will raise mentioned output.

Comment 11 errata-xmlrpc 2011-01-13 23:47:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0122.html


Note You need to log in before you can comment on or make changes to this bug.