Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598910 - Hangs during desktop use
Summary: Hangs during desktop use
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 10:40 UTC by Tim Waugh
Modified: 2010-06-21 12:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-21 12:31:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tim Waugh 2010-06-02 10:40:36 UTC
Description of problem:
Twice this morning this EL-6 installation has frozen while I was reading email.  The first time it was a few seconds after an automatic local backup (using rsync) had started from cron.  The second time it was shortly (some minutes) after connecting, but not using, a USB mass storage device.

Version-Release number of selected component (if applicable):
2.6.32-31.el6.x86_64

How reproducible:
Haven't found any way to reproduce it.

Additional info:
There was nothing of note in /var/log/messages or any other log file.  The machine was responsive to PING on the (wired) network, but I could not log in via ssh.

When the machine froze, the X display stayed the same but the mouse cursor no longer moved.

Comment 2 Tim Waugh 2010-06-02 11:35:00 UTC
Just happened again.  I had just started a virtual kvm guest, was listening to music stored on an NFS mount, and other desktop tasks.  The music that had been playing was repeatedly looping over about the last half-second of playback.

Comment 3 Bill Nottingham 2010-06-02 19:30:15 UTC
Any chance you can get netconsole output?

Comment 4 Tim Waugh 2010-06-03 10:43:09 UTC
I had a go at this today, and turned on SysRq handling as well so I could sync and remount r/o.  After it hung, here's the netconsole output I found:

SysRq : Emergency Sync
SysRq : Emergency Remount R/O
SysRq : Emergency Sync
SysRq : Resetting

i.e. there was no console output at all between loading the netconsole module and the machine hanging -- and console output (and SysRq handling) was still working after that point.

What else can I try?

Comment 5 Bill Nottingham 2010-06-03 16:08:22 UTC
If sysrq is working, dump the processes, stack, etc.

Comment 6 RHEL Product and Program Management 2010-06-07 16:05:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 7 Stanislaw Gruszka 2010-06-17 21:07:08 UTC
Looks like live lock. Try to use -debug kernel, it should log info where problem is.

Comment 8 Tim Waugh 2010-06-21 12:31:32 UTC
I haven't seen this happen at all with recent kernel updates.


Note You need to log in before you can comment on or make changes to this bug.