Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598894 - nfsv4 clients are not aware of files changes on servers
Summary: nfsv4 clients are not aware of files changes on servers
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 09:58 UTC by Francois Marabelle
Modified: 2011-10-03 22:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 22:20:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Francois Marabelle 2010-06-02 09:58:17 UTC
Description of problem:

Using nfsv4, clients do not see changes mad to a file on server. Changes can
be seen sometimes after a few minutes. Only a ls command on client update the file

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. edit a file on nfsv4 server. Make change
2. edit file on client. Change is not seen
3. enter "ls" command on client.
4. edit file on client. change is seen
  
Actual results:
File's changes on client side are seen randomly after long delay.

Expected results:
change to a file should be seen at once

Additional info:
Working well with nfsv3
Working well with Fedora 12 nfsv4 server and RH el5.5 client
using "noac" mount option has no effect
Changes mades on file on client side are seen at on server side

Comment 1 Francois Marabelle 2010-07-22 09:07:59 UTC
More tests:
The problem can be seen between two nfs4 clients. The first change on file is 
seen, but not the second one
Same problem with EL6 beta (2.6.32-37.el6.i686) as file server.

Comment 2 J. Bruce Fields 2011-02-07 16:27:39 UTC
If you "echo 0 >/proc/sys/fs/leases-enable" before starting the server, is the problem still reproduceable?

Which filesystem are you exporting?

Comment 3 Francois Marabelle 2011-02-08 14:49:52 UTC
The problem seems solved with "echo 0 >/proc/sys/fs/leases-enable".
I also check that the problem doesn't exist on RH EL6.

The filesystem is (from /etc/fstab):
/dev/sdc2		/mnt/scout		ext3	defaults	1 2

Comment 4 J. Bruce Fields 2011-02-08 17:26:34 UTC
If turning off leases eliminates the problem, then it's almost certainly the problem reported in 610093.

However the patch attached to 610093 only solves the problem for conflicts between two NFS clients, not between an NFS client and local users on the server, so we should keep this bug open for now.

The same problem exists on RHEL6, but there are a number of reasons why you might not see it there any more, depending on which you updated to RHEL6 (client or server) and whether the network configuration also changed in any way.

Comment 5 J. Bruce Fields 2011-10-03 22:20:25 UTC

*** This bug has been marked as a duplicate of bug 683692 ***


Note You need to log in before you can comment on or make changes to this bug.