Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598864 - SELinux preventing /usr/bin/openconnect "read" access to /etc/pki/tls/certs/ca-bundle.crt.
Summary: SELinux preventing /usr/bin/openconnect "read" access to /etc/pki/tls/certs/c...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
: 601685 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 08:53 UTC by David Woodhouse
Modified: 2010-06-11 14:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 12:30:42 UTC


Attachments (Terms of Use)

Description David Woodhouse 2010-06-02 08:53:42 UTC
(Gr, why couldn't I cut and paste that summary from the warning dialog which popped up to show me this?)

node=macbook.infradead.org type=AVC msg=audit(1275468285.578:14): avc: denied { read } for pid=2343 comm="openconnect" name="ca-bundle.crt" dev=sda3 ino=1296658 scontext=system_u:system_r:vpnc_t:s0 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file node=macbook.infradead.org type=AVC msg=audit(1275468285.578:14): avc: denied { open } for pid=2343 comm="openconnect" name="ca-bundle.crt" dev=sda3 ino=1296658 scontext=system_u:system_r:vpnc_t:s0 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file node=macbook.infradead.org type=SYSCALL msg=audit(1275468285.578:14): arch=c000003e syscall=2 success=yes exit=5 a0=379033a643 a1=0 a2=1b6 a3=0 items=0 ppid=2333 pid=2343 auid=4294967295 uid=491 gid=0 euid=491 suid=491 fsuid=491 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="openconnect" exe="/usr/bin/openconnect" subj=system_u:system_r:vpnc_t:s0 key=(null)

Comment 1 Daniel Walsh 2010-06-02 12:30:42 UTC
Looks like you have a crt file labeled user_tmp_t?

/etc/pki/tls/certs/ca-bundle.crt is mislabeled

restorecon -R -v /etc/pki

Should fix.

There is a copy button on the troubleshooter that will copy all the info into the cut buffer.  Also there should be a report bug button or fix button.

Comment 2 David Woodhouse 2010-06-02 12:55:17 UTC
Oops, stupid me -- I should have spotted that and remembered that I'd screwed with the file recently (albeit before the upgrade to F-13 and I only started seeing the report after the upgrade).

Thanks.

Comment 3 Ken Giusti 2010-06-11 14:58:05 UTC
*** Bug 601685 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.