Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598833 - should the dates in the revision history be right aligned ?
Summary: should the dates in the revision history be right aligned ?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Publican
Classification: Community
Component: publican
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 06:45 UTC by Dana Mison
Modified: 2010-11-24 04:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-12 03:51:43 UTC


Attachments (Terms of Use)

Description Dana Mison 2010-06-02 06:45:44 UTC
Description of problem:
In the html outputs, the dates in the revision history are right aligned, which IMHO makes them look mis-aligned since we read left to right.  

I think it looks okay for the author names to be right aligned since they are in the far right column.

The PDF is formatted as I would expect that the author names are left aligned as well.

Version-Release number of selected component (if applicable):
1.6.3

How reproducible:
everytime :-)

Steps to Reproduce:
1. create a book with items in revision history
2. view revision history

  
Actual results:
revision history headers are right aligned with the exception of the first

Expected results:
revision history headers are left aligned with the possible exception of the last


Additional info:
edited common.css 

.revhistory td {
        text-align:left;
        padding:0em;
        border: none;
        border-top: 1px solid #fff;
}

could leave this out entirely and have it match the PDF
.revhistory tr td:last-child {
        text-align:right;
}

The table cells also have alignment set, which is being overridden by CSS, <td align="left">

Comment 1 Jeff Fearn 🐞 2010-06-10 04:03:40 UTC
Right aligned all cells in PDF and HTML.

Fixed in build: 1.6.3-0.t101

Comment 2 Ruediger Landmann 2010-07-12 03:51:43 UTC
Confirmed fixed in 2.1


Note You need to log in before you can comment on or make changes to this bug.