Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598812 - gnome-volume-control does not function without PulseAudio
Summary: gnome-volume-control does not function without PulseAudio
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 05:05 UTC by Derek
Modified: 2010-09-08 22:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-08 12:45:11 UTC


Attachments (Terms of Use)

Description Derek 2010-06-02 05:05:00 UTC
Description of problem: gnome-volume-control cannot function without PulseAudio, forcing us to fall back onto gmixer.  PulseAudio is a disaster for many users, utterly ruining linux audio.  gnome-volume-control should be able to function without pulse audio.


Version-Release number of selected component (if applicable): Fedora 13


How reproducible: Every sound card i've tried (emu10k1-based, ALC888-based, cmipci-based) has issues with Pulse that are only solved by removing Pulse.  Removing Pulse breaks gnome-volume-control


Steps to Reproduce:
1. yum remove alsa-plugins-pulseaudio pulseaudio padevchooser pavumeter paprefs pavucontrol
2. reboot/relog
3. attempt to use gnome-volume-control
  
Actual results:
gnome-volume-control fails to function

Expected results:
gnome-volume-control behaves as it does with Pulse

Additional info:

Comment 1 Bastien Nocera 2010-09-08 12:45:11 UTC
gnoem-volume-control doesn't work without PulseAudio, because it's a front-end to PulseAudio.

Comment 2 Derek 2010-09-08 22:18:33 UTC
yes this is a bug, because the non-pulseaudio volume control that nicely integrates with the tray was removed.  so gnome-volume-control should support both.  IMHO PulseAudio shouldn't even be installed on distros, but obviously the "shiny new features that break things" crowd continues to screw up distros.


Note You need to log in before you can comment on or make changes to this bug.