Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598680 - token retransmissions reset last_aru to current token's aru.
Summary: token retransmissions reset last_aru to current token's aru.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 598689
TreeView+ depends on / blocked
 
Reported: 2010-06-01 20:20 UTC by Steven Dake
Modified: 2016-04-26 14:49 UTC (History)
1 user (show)

Fixed In Version: corosync-1.2.3-2.el6
Doc Type: Bug Fix
Doc Text:
An internal protocol variable was set on retransmission when it should only have been set on the first transmission. With this update, the aforementioned variable is only set on the first transmission.
Clone Of:
: 598689 (view as bug list)
Environment:
Last Closed: 2010-11-15 13:53:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
trunk revision 2917 (deleted)
2010-06-01 20:37 UTC, Steven Dake
no flags Details | Diff

Description Steven Dake 2010-06-01 20:20:05 UTC
Description of problem:
token retransmissions reset last_aru to current token's aru.

Version-Release number of selected component (if applicable):
corosync-1.2.3-1.el6

How reproducible:
not sure how to generate a fault

Could be a serious problem in lossy network environments.

Totem spec is clear:

reject retransmitted tokens
if token.aru = aru in token on last rotation ... do some logic

Here is how the current code works:

last_aru = instance->my_last_aru;
instance->my_last_aru = token->aru;
reject retransmitted tokens
if token.aru = aru in token on last rotation ... do some logic

The issue is last_aru will be set to token->aru when a token retransmission occurs before a new token arrives.

This results in the "do some logic" part happening more often then it should.

Comment 1 RHEL Product and Program Management 2010-06-01 20:26:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Steven Dake 2010-06-01 20:37:34 UTC
Created attachment 418808 [details]
trunk revision 2917

Comment 4 releng-rhel@redhat.com 2010-11-15 13:53:38 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Comment 5 Douglas Silas 2011-01-11 23:15:09 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An internal protocol variable was set on retransmission when it should only have been set on the first transmission. With this update, the aforementioned variable is only set on the first transmission.


Note You need to log in before you can comment on or make changes to this bug.