Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598610 - operations fail on an inventoried tomcat6 server
Summary: operations fail on an inventoried tomcat6 server
Keywords:
Status: CLOSED DUPLICATE of bug 604444
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 3.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks: rhq_auto_blocker
TreeView+ depends on / blocked
 
Reported: 2010-06-01 17:49 UTC by John Sefler
Modified: 2010-06-22 15:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 15:17:05 UTC


Attachments (Terms of Use)

Description John Sefler 2010-06-01 17:49:09 UTC
Description of problem:
After successful inventory of a tomcat6 resource, attempts to run the Shutdown operation fail.

Server Identifier: Apache Tomcat/6.0.18


Version-Release number of selected component (if applicable):
 RHQ
version: 3.0.0-SNAPSHOT
build number: 11e04e1 

How reproducible:


Steps to Reproduce:
1. Open inventoried resource Tomcat (8080)
2. click Operations > New > Shutdown > SCHEDULE
  
Actual results:
Failure

The agent.log contains:

2010-06-01 13:37:51,088 WARN  [ResourceDiscoveryComponent.invoker.daemon-24] (jboss.on.plugins.tomcat.TomcatDiscoveryComponent)- Failed to determine Tomcat Server Version Given:
VersionInfo:/root/JBossEWS100/jboss-ews-1.0/tomcat6/bin/catalina.sh: line 362: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java: No such file or directory

catalinaHome: /root/JBossEWS100/jboss-ews-1.0/tomcat6
Script:/root/JBossEWS100/jboss-ews-1.0/tomcat6/bin/version.sh
timeout=10000


My environment vars are:
[root@rlx-0-04 bin]# env | grep HOME
CATALINA_HOME=/root/JBossEWS100/jboss-ews-1.0/tomcat6
JAVA_HOME=/usr/lib/jvm/jre-openjdk/


I can successfully run version.sh from the command line:

[root@rlx-0-04 bin]# ./version.sh 
Using CATALINA_BASE:   /root/JBossEWS100/jboss-ews-1.0/tomcat6
Using CATALINA_HOME:   /root/JBossEWS100/jboss-ews-1.0/tomcat6
Using CATALINA_TMPDIR: /root/JBossEWS100/jboss-ews-1.0/tomcat6/temp
Using JRE_HOME:       /usr/lib/jvm/jre-openjdk/
Server version: Apache Tomcat/6.0.18
Server built:   Mar 25 2009 04:09:44
Server number:  6.0.18.0
OS Name:        Linux
OS Version:     2.6.18-128.el5
Architecture:   i386
JVM Version:    1.6.0-b09
JVM Vendor:     Sun Microsystems Inc.


Line 362 of catalina.sh is:
    359 elif [ "$1" = "version" ] ; then
    360 
    361     $_RUNJAVA   \
    362       -classpath "$CATALINA_HOME/lib/catalina.jar" \
    363       org.apache.catalina.util.ServerInfo





[root@rlx-0-04 bin]# ls -l /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0
total 8
drwxr-xr-x 4 root root 4096 Sep  9  2009 jre

[root@rlx-0-04 bin]# echo $JAVA_HOME
/usr/lib/jvm/jre-openjdk/
[root@rlx-0-04 bin]# ls $JAVA_HOME
bin  lib




I'm not sure where the bad path /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/java is coming from.



Additional info:

Comment 1 John Sefler 2010-06-22 15:17:05 UTC

*** This bug has been marked as a duplicate of bug 604444 ***


Note You need to log in before you can comment on or make changes to this bug.