Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598493 - KeyError: 'setuptime'
Summary: KeyError: 'setuptime'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 13:55 UTC by James Laska
Modified: 2014-09-30 23:39 UTC (History)
9 users (show)

Fixed In Version: anaconda-14.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 568334
Environment:
Last Closed: 2010-07-19 10:40:53 UTC


Attachments (Terms of Use)

Description James Laska 2010-06-01 13:55:46 UTC
Originally filed in existing bug#568334.  For full traceback dump, see attachment#417416 [details]

--- Additional comment from cjm@tryx.org on 2010-05-27 18:48:23 EDT ---

anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/text.py", line 597, in run
    (file, classNames) = stepToClasses[step]
  File "/usr/bin/anaconda", line 1223, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'setuptime'

Local variables in innermost frame:
nextWindow: PartitionTypeWindow.PartitionTypeWindow
win: <PartitionTypeWindow.PartitionTypeWindow instance at 0xb5906cec>
self: <text.InstallInterface object at 0xb7277e6c>
args: <__main__.Anaconda object at 0xb709652c>
rc: -1
anaconda: <__main__.Anaconda object at 0xb709652c>
instance: <__main__.Anaconda object at 0xb709652c>
classNames: ('PartitionTypeWindow',)
lastrc: -1
file: partition_text
loaded: <module 'PartitionTypeWindow' from '/usr/lib/anaconda/textw/partition_text.py'>
step: setuptime
found: (<open file '/usr/lib/anaconda/textw/partition_text.py', mode 'U' at 0xb5922d90>, '/usr/lib/anaconda/textw/partition_text.py', ('.py', 'U', 1))
foo: parttype
instLang: <language.Language object at 0xb593c0ec>

Comment 1 Chris Miller 2010-06-01 14:31:44 UTC
This was a long day...  And, of course, I have a few comments.  :-)

I installed a lot of packages with kickstart.  The installation failed at about the 60% point.

First comment: Guys, I had invested hours in this installation.  Is there a way that exceptions can be caught, logged and the installation resumed?  I KNOW it claims “unhandled exception”, but there should be a catch-all handler, so that all of them are handled.

I subsequently struggled with an array of unknown exceptions and I think they were the result of the mirror list pointing me to a different mirror – one with a corrupt package, but I can’t be sure.  I filed a dozen reports over the course of the day and grumbled under my breath and I blamed you guys.  I hope I was wrong.  Please investigate all the bugs I filed on that day, since they are all related to this one single installation.

Eventually, I succeeded without the mirror list layer.

I don’t know if it is important, but there are at least two things that I was doing differently from a “normal” installation.  The installation repo was not burned to physical optical media and I used a virtual machine to manage the installation.

1) I had the DVD on the local disk as iso, and my extlinux stanza looked like this:

LABEL ins-F13-ks
	MENU LABEL ^KickStart Ins / Upg Fedora-13 (<F4> Edit Kernel Options Help)
	KERNEL /Fedora-13/isolinux/vmlinuz
	APPEND initrd=/Fedora-13/isolinux/initrd.img ro lang=en_US keymap=us ksdevice=eth0 ip=dhcp graphical ks=hd:/dev/sda1:/Fedora-13/ks.cfg

2) I was installing to the 250G disk while running linux from a 4G USB key drive (NOT with the useroverlay foolishness) and I used virt-manager to run qemu-kvm which is how I booted into the installation.  As you can see from the extlinux stanza, I did NOT simply point the virtual CD-ROM to the iso.

Comment 2 James Laska 2010-06-01 16:15:08 UTC
(In reply to comment #1)
> This was a long day...  And, of course, I have a few comments.  :-)
> 
> I installed a lot of packages with kickstart.  The installation failed at about
> the 60% point.

Deploying linux on a lot of systems certainly takes time.  Thank you for providing feedback.
 
> First comment: Guys, I had invested hours in this installation.  Is there a way
> that exceptions can be caught, logged and the installation resumed?  I KNOW it
> claims “unhandled exception”, but there should be a catch-all handler, so that
> all of them are handled.

It certainly can be frustrating when you spend a lot of time working around a problem that affects you.  I'm not aware of a method to properly detect and resolve/work-around arbitrary failures.  As always, the anaconda developers welcome ideas in the form of code.  To contribute, see https://www.redhat.com/archives/anaconda-devel-list/.

In this case, I would recommend first helping to analyze the root cause of the failure.  From there, we can make recommendations for future action.  Until then, it would be difficult to make development recommendations.

> I subsequently struggled with an array of unknown exceptions and I think they
> were the result of the mirror list pointing me to a different mirror – one with
> a corrupt package, but I can’t be sure.  I filed a dozen reports over the
> course of the day and grumbled under my breath and I blamed you guys.  I hope I
> was wrong.  Please investigate all the bugs I filed on that day, since they are
> all related to this one single installation.
> 
> Eventually, I succeeded without the mirror list layer.

I recommend keeping discussion in each bug report focused on the specific topic.  For the problems related to mirrorlist and hard drive (and hard drive ISO) install failures, please direct feedback to bug#573492.  Please continue to discuss the "KeyError: 'setuptime' failure in this bug report.

> I don’t know if it is important, but there are at least two things that I was
> doing differently from a “normal” installation.  The installation repo was not
> burned to physical optical media and I used a virtual machine to manage the
> installation.
> 
> 1) I had the DVD on the local disk as iso, and my extlinux stanza looked like
> this:
> 
> LABEL ins-F13-ks
>  MENU LABEL ^KickStart Ins / Upg Fedora-13 (<F4> Edit Kernel Options Help)
>  KERNEL /Fedora-13/isolinux/vmlinuz
>  APPEND initrd=/Fedora-13/isolinux/initrd.img ro lang=en_US keymap=us
> ksdevice=eth0 ip=dhcp graphical ks=hd:/dev/sda1:/Fedora-13/ks.cfg
> 
> 2) I was installing to the 250G disk while running linux from a 4G USB key
> drive (NOT with the useroverlay foolishness) and I used virt-manager to run
> qemu-kvm which is how I booted into the installation.  As you can see from the
> extlinux stanza, I did NOT simply point the virtual CD-ROM to the iso.    

Thanks, that feedback will be helpful in the other bug report (see bug#573492), along with the kickstart file used to produce the failure.

Comment 3 Ales Kozumplik 2010-07-14 07:47:09 UTC
Hello Chris, 

thanks for reporting this. The installation path you've chosen is not very well tested and unfortunately a bit broken.

I manged to reproduce:
1) have a kicstart specifying your timezone, root password and bootloader. Request text install too.
2) The first TUI screen that ever appears is partitioning. Click 'Back'.
3) 'I can't go to the previous step from here' dialog emerges. That's good. Click 'OK'
4) The exception arrives.

I'll be preparing a fix for rawhide (F14).

Comment 4 Ales Kozumplik 2010-07-19 10:40:53 UTC
Fixed rawhide by 35e61b016bd1a83bbb4941622f93a36d9b13dacd, will be in anaconda-14.12.


Note You need to log in before you can comment on or make changes to this bug.