Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598486 - Error 'Not on the same file system' while moving a file to the trash (if the folder is accessed using a symlink)
Summary: Error 'Not on the same file system' while moving a file to the trash (if the ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-vfs2
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 13:41 UTC by Ivan Stojmirov
Modified: 2014-09-29 15:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:09:22 UTC
Target Upstream Version:
istojmir: needinfo-


Attachments (Terms of Use)

Description Ivan Stojmirov 2010-06-01 13:41:33 UTC
Description of problem:
Files which are residing in a folder on a different partition can not be moved to the Trash if the folder is accessed using a symlink. Nautilus throws: Error 'Not on the same file system' 

Version-Release number of selected component (if applicable):
gnome-vfs2-smb-2.16.2-6.el5_5.1.i386.rpm (latest available)

How reproducible:

Steps to Reproduce:
1. Create a test file in /partition2/foo/file.txt
2. Create a symlink to /partition2 on your desktop
3. Double click on the symlink on the desktop, then double click on the foo folder and try to delete file.txt
  
Actual results:
The file is not moved to the Trash folder. 
Nautilus throws: Error 'Not on the same file system' 

Expected results:
Successfully move the file into the Trash folder.

Additional info:
If the /partition2/foo folder is accessed directly, without using the symlink, the file can be successfully moved to Trash.

Comment 2 Ivan Stojmirov 2010-08-13 13:32:25 UTC
Still reproducible.

Comment 3 Tomáš Bžatek 2010-08-27 12:14:36 UTC
Still couldn't reproduce this bug on my system. Packages are stock nautilus-2.16.2-7.el5 and gnome-vfs2-2.16.2-6.el5_5.1. 

Files are physically located in /data2 and symlinked to desktop, both the mountpoint and a subdirectory containing test file. I can delete anything from symlinked folders, giving me the 'The file "tmp" cannot be moved to the trash.' message (i.e. not trashing but deleting directly).

Comment 4 Ivan Stojmirov 2010-08-30 11:29:48 UTC
I can delete directly (using SHIFT+DEL), but moving to trash fails (just DEL).

gnome-vfs2-2.16.2-8.el5
nautilus-2.16.2-7.el5

What do you need from my side in order to troubleshoot this?

Comment 5 Anthony Avarca 2010-10-04 16:56:57 UTC
I'm also experiencing a similar issue. When moving a file from one NFS share to another I receive: "error not on the same file system." I'm running: gnome-vfs2-2.16.2-6.el5_5.1.x86_64.rpm

Comment 7 RHEL Product and Program Management 2011-09-23 00:50:30 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2014-03-07 13:41:13 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 9 RHEL Product and Program Management 2014-06-02 13:09:22 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.