Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598436 - ORA-00911 on schema upgrade
Summary: ORA-00911 on schema upgrade
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Installer
Version: 3.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 12:02 UTC by Thilo Solbrig
Modified: 2010-09-24 12:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-24 12:47:17 UTC


Attachments (Terms of Use)

Description Thilo Solbrig 2010-06-01 12:02:20 UTC
Description of problem:
Upgrade of Oracle database schema to version 3.0.0B06 fails with ORA-00911: invalid character

Version-Release number of selected component (if applicable):
3.0.0B06

How reproducible:
Install server 3.0.0B06 on an existing schema and choose "Keep (maintain existing data)"

Steps to Reproduce:
1.
2.
3.
  
Actual results:
ORA-00911 reported, upgrade fails

Expected results:
Schema to upgrade correctly

Additional info:
ORA-00911 is caused by a wrong entry in jbossas/server/default/deploy/rhq-installer.war/WEB-INF/lib/rhq-core-dbutils-3.0.0.B06.jar, db-upgrade.xml:
found:
                   <statement desc="Make RHQ_RES_TYPE_IDX_PLG_NAME index unique">
                       DROP INDEX RHQ_RES_TYPE_IDX_PLG_NAME ;
                       CREATE UNIQUE INDEX RHQ_RES_TYPE_IDX_PLG_NAME ON RHQ_RESOURCE_TYPE (name, plugin)
                   </statement>

should rather be:
                   <statement desc="Make RHQ_RES_TYPE_IDX_PLG_NAME index unique">
                       DROP INDEX RHQ_RES_TYPE_IDX_PLG_NAME
                   </statement>
                    <statement>
                       CREATE UNIQUE INDEX RHQ_RES_TYPE_IDX_PLG_NAME ON RHQ_RESOURCE_TYPE (name, plugin)
                   </statement>

Comment 1 Corey Welton 2010-09-24 12:47:17 UTC
Per triage, closing: don't support dbupgrade from beta releases


Note You need to log in before you can comment on or make changes to this bug.