Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598415 - ValueError: No closing quotation
Summary: ValueError: No closing quotation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: livecd-tools
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 11:20 UTC by Jens Petersen
Modified: 2010-10-14 09:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-23 08:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
anaconda.log (deleted)
2010-06-07 02:33 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2010-06-01 11:20:03 UTC
Description of problem:
After loading install.img I get a backtrace
while anaconda tries to start stage2.

Version-Release number of selected component (if applicable):
13.21.49

How reproducible:
every time

Steps to Reproduce:
1. do a baremetal net install of RHEL6.0-20100531.n.0
2.
3.
  
Actual results:
Running anaconda 13.21.49, the [RHEL] system installer - please wait.
Traceback (most recent call last):
:
  File "/usr/lib/anaconda/flags.py", line 55, in createCmdlineDict
    lst = shlex.split(cmdline)
:
  File "/usr/lib64/python2.6/shlex.py", line 172, in read_token
    raise ValueError, "No closing quotation"
:
install exited abnormally [1/1]
:

Expected results:
No backtrace - GUI stage2 installer to run.

Additional info:
Installed ok as a kvm guest.

Note boot.iso was booted from a live usb stick but that shouldn't matter I think.

Comment 2 Chris Lumens 2010-06-01 14:54:31 UTC
Please attach the complete traceback to this bug report.

Comment 3 Jens Petersen 2010-06-01 23:34:37 UTC
Ok (heh - you mean type?:)

Comment 4 Jens Petersen 2010-06-02 09:36:11 UTC
Running anaconda 13.21.49, the Red Hat Enterprise Linux system installer - please wait.
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 647, in <module>
    import signal, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 33, in <module>
    import iutil
  File "/usr/lib/anaconda/iutil.py", line 30, in <module>
    from flags import flags
  File "/usr/lib/anaconda/flags.py", line 121, in <module>
    flags = Flags()
  File "/usr/lib/anaconda/flags.py", line 91, in __init__
    self.__dict__['flags']['cmdline'] = self.createCmdlineDict()
  File "/usr/lib/anaconda/flags.py", line 55, in createCmdlineDict
    lst = shlex.split(cmdline)
  File "/usr/lib/python2.6/shlex.py", line 279, in split
    return list(lex)
  File "/usr/lib/python2.6/shlex.py", line 269, in next
    token = self.get_token()
  File "/usr/lib/python2.6/shlex.py", line 96, in get_token
    raw = self.read_token()
  File "/usr/lib/python2.6/shlex.py", line 172, in read_token
    raise ValueError, "No closing quotation"
ValueError: No closing quotation
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

Comment 5 RHEL Product and Program Management 2010-06-02 09:45:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Chris Lumens 2010-06-02 15:26:31 UTC
Well, what I meant was the full /tmp/anaconda-*-tb file.  But that's not really necessary.  What I was looking for was /proc/cmdline and the command line being passed to loader and anaconda.  You can grab the latter two by looking in /proc/<pid>/cmdline.

Comment 7 Jens Petersen 2010-06-03 02:16:53 UTC
thanks - np, will be back at my test machine tomorrow

Comment 8 Jens Petersen 2010-06-04 02:39:08 UTC
You'll have to give me more clues:

[anaconda root@myhost]# ls /tmp/anaconda*
/tmp/anaconda.log

/usr/bin/anaconda already backtraced so I don't how to get
the cmdline.

Comment 9 Jens Petersen 2010-06-04 05:02:27 UTC
Still happens with 13.21.50 and RHEL6.0-20100603.n.0 nightly tree fwiw.

Comment 10 Chris Lumens 2010-06-04 13:42:45 UTC
The anaconda.log will work.  You can attach that.

Comment 11 Jens Petersen 2010-06-07 02:33:14 UTC
Created attachment 421700 [details]
anaconda.log

Ah I see doh: I looked at it last time and thought it didn't
look useful but now I see the `"' in the kernel args...

Comment 12 Jens Petersen 2010-06-07 02:35:26 UTC
I guess this probably is usb boot specific then but still it shouldn't happen.

(I am still kind of surprised that we don't officially
support net install from usb, or do we?)

Comment 13 Jens Petersen 2010-06-07 03:26:17 UTC
Yeah if I edit out the "Hat Enterprise Linux\"" from the boot.iso
kernel args then the installer moves ok to stage 2.

Comment 14 David Cantrell 2010-06-10 17:53:10 UTC
This is not an anaconda bug.  If you used a tool like pungi or livecd-creator to make the USB boot media, the bug lies there, so if you reopen it, make sure you reassign it to the correct component.

Comment 15 Chris Lumens 2010-06-21 14:54:38 UTC
*** Bug 575982 has been marked as a duplicate of this bug. ***

Comment 16 Tom Lane 2010-06-21 17:31:54 UTC
I've had this same problem while trying to use livecd-tools to make a USB stick for installation of RHEL6.  Per bug #575982, particularly comment 10, the kernel gets booted with bogus parameters.

There seems to be an additional issue that livecd-tools puts a copy of the RHEL6 ISO on the USB stick but the installer is unable to find it, even with the bogus repo parameter changed to just "repo=hd:UUID=047E-4654".  Is there some other value of that parameter that should be used to get it to notice the USB-stick copy?  I was able to complete the installation by pointing to install files on an NFS server, but that was less than convenient.

Comment 17 Alan Pevec 2010-06-22 23:08:42 UTC
This livecd-iso-to-disk feature was added by the upstream commit
http://git.fedoraproject.org/git/?p=livecd;a=commitdiff;h=09678eb9284f2df7618c4609998fd3bd95787251

It was controversial and never actually ACKed on list, since the scope of that script is to support LiveCD ISO only. I propose to drop it from RHEL-6.

Comment 19 Jens Petersen 2010-06-23 05:56:57 UTC
So how to bootstrap an install from USB?  Or do we have to burn more trees^WCDs? :)  It is some years since I last burned boot.iso to a CD-RW...

Comment 20 Alan Pevec 2010-06-23 08:19:46 UTC
(In reply to comment #19)
> So how to bootstrap an install from USB?  Or do we have to burn more
> trees^WCDs? :)  It is some years since I last burned boot.iso to a CD-RW...    

There are disk images (.img in images folder) or even boot.iso is now hybrid so you can simply dd it to the USB stick, see documented procedure:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/Installation_Guide/Making_USB_Media.html


Note You need to log in before you can comment on or make changes to this bug.