Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598389 - F13 anaconda fails at grub stage : IndexError: list index out of range
Summary: F13 anaconda fails at grub stage : IndexError: list index out of range
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:9443e8c3ba33da9ec...
: 640893 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 09:40 UTC by Lutz Lange
Modified: 2010-12-03 14:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-03 14:08:16 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2010-06-01 09:40 UTC, Lutz Lange
no flags Details
Traceback from anaconda (deleted)
2010-07-05 23:45 UTC, Steve
no flags Details

Description Lutz Lange 2010-06-01 09:40:13 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/backend.py", line 160, in mountInstallImage
    free[-1][0])
  File "/usr/lib/anaconda/backend.py", line 207, in freetmp
    if self.mountInstallImage(anaconda, stage2img):
  File "/usr/lib/anaconda/yuminstall.py", line 1153, in doBackendSetup
    anaconda.backend.freetmp(anaconda)
  File "/usr/lib/anaconda/backend.py", line 282, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
IndexError: list index out of range

Comment 1 Lutz Lange 2010-06-01 09:40:18 UTC
Created attachment 418556 [details]
Attached traceback automatically from anaconda.

Comment 2 Lutz Lange 2010-06-01 13:14:56 UTC
This happened when booting anaconda via grub. I tried the preupgrade but hat difficulties with putting the install.img on /boot/upgrade ( /boot was full /boot/upgrade was on LVM ) 

My system was connected via Ethernet cable and got the install.img from the network. The error occurred near the point where the bootloader should be written to disc.

Comment 3 Steve 2010-07-05 23:45:14 UTC
Created attachment 429623 [details]
Traceback from anaconda

I'm getting the same problem, trying to upgrade an FC 10 machine to FC 13, using the preupgrade method.  Here's the traceback from anaconda for my crash.

Previously, I tried upgrading the same machine to FC11 and then FC12, but you can see case 557989 to see where I left off with that -- I keep getting a bogus "Dirty file systems" error.

Comment 4 Chris Lumens 2010-10-07 13:50:07 UTC
*** Bug 640893 has been marked as a duplicate of this bug. ***

Comment 5 chris.arrowood 2010-10-08 02:22:53 UTC
This happens for me both with preupgrade (after the reboot) and when trying to upgrade from the DVD. :-(

Comment 6 Bug Zapper 2010-11-03 13:45:34 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Bug Zapper 2010-12-03 14:08:16 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.