Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598345 - All files on NFS exports from Solaris are owned by nobody:nobody since F13 upgrade
Summary: All files on NFS exports from Solaris are owned by nobody:nobody since F13 up...
Keywords:
Status: CLOSED DUPLICATE of bug 600936
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 06:45 UTC by Tore Anderson
Modified: 2010-06-07 17:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-07 17:01:44 UTC


Attachments (Terms of Use)

Description Tore Anderson 2010-06-01 06:45:57 UTC
Description of problem:

After I upgraded my workstation from F12 to F13, all the NFS mounts from Solaris servers (OpenSolaris and Storage 7000 appliances) have all their files owner by nobody:nobody.

Version-Release number of selected component (if applicable):

F13, nfs-utils-1.2.2-2.fc13.x86_64

How reproducible:

100%

Steps to Reproduce:
1. mount -t nfs server:/export /mountpoint
2. ls -l /mountpoint
  
Actual results:

All the files are owned by nobody:nobody.

Expected results:

The files should be owner by their correct owner.

Additional info:

Adding "-o nfsvers=3" to the step #1 makes the problem go away.

Comment 1 Michael Young 2010-06-04 15:35:40 UTC
I am seeing something similar to this and I have lots of errors like
rpc.idmapd[pid]: nss_getpwnam: name 'user@nisdomain' does not map into
domain 'dnsdomain'
I tried setting Domain = nisdomain
but then I get similar errors with dnsdomain and nisdomain swapped.

Comment 2 Jeff Layton 2010-06-07 17:01:44 UTC

*** This bug has been marked as a duplicate of bug 600936 ***


Note You need to log in before you can comment on or make changes to this bug.