Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598329 - redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic_user'
Summary: redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 05:53 UTC by Jan Hutař
Modified: 2014-07-04 13:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:24:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2010-06-01 05:53:56 UTC
Description of problem:
When I'm restarting various services of Satellite, I get traceback in my (root's) mailbox.


Version-Release number of selected component (if applicable):
RHN Satellite 5.3.0 + erratas


How reproducible:
sometimes, mostly in RHTS


Steps to Reproduce:
1. run RHTS test /CoreOS/RHN-Satellite/Installer/Sanity/restartable-services


Actual results:
I see traceback in RHTS as in:
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=14463437
(see _var_spool_mail_root file in attached logs.160494_411386_3359674.tar.gz)

Expected results:
There should be no traceback generated


Additional info:
For now, I have disabled that check in the test, so you have to comment out the check:

http://cvs.devel.redhat.com/cgi-bin/cvsweb.cgi/tests/RHN-Satellite/Installer/Sanity/restartable-services/runtest.sh.diff?r1=1.20;r2=1.21;f=h

Manual run seems not to generate such a traceback, only automated one in RHTS.

Traceback from the mailbox is:

com.redhat.rhn.manager.kickstart.cobbler.NoCobblerTokenException: We had an error trying to login.
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:57)
	at com.redhat.rhn.frontend.integration.IntegrationService.authorize(IntegrationService.java:114)
	at com.redhat.rhn.frontend.integration.IntegrationService.getAuthToken(IntegrationService.java:67)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.<init>(CobblerCommand.java:68)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerDistroSyncCommand.<init>(CobblerDistroSyncCommand.java:49)
	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:83)
	at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic_user'
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:52)
	... 8 more


Note You need to log in before you can comment on or make changes to this bug.