Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598300 - Xchat's spell checking feature does not work in fedora 13 64bit
Summary: Xchat's spell checking feature does not work in fedora 13 64bit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 695562 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 03:13 UTC by fedora-bugzilla
Modified: 2011-04-12 02:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 05:35:00 UTC


Attachments (Terms of Use)

Description fedora-bugzilla 2010-06-01 03:13:24 UTC
Description of problem:
The spell checker in xchat does not work.

Version-Release number of selected component (if applicable): 
xchat 2.8.6 17.fc13


How reproducible:
Every time i start xchat i encounter this problem

Steps to Reproduce:
1. Install xchat
2. Enable spell check in settings -> preferences -> input box -> check spelling
3. Type in input box
  
Actual results:
No spelling corrections 


Expected results:
Spelling corrections


Additional info:

Comment 1 Kevin Kofler 2010-06-02 05:18:59 UTC
Please post the output of:
rpm -q xchat libsexy enchant hunspell hunspell-en

Comment 2 fedora-bugzilla 2010-06-02 05:26:47 UTC
rpm -q xchat libsexy enchant hunspell hunspell-en
xchat-2.8.6-17.fc13.x86_64
libsexy-0.1.11-15.fc13.x86_64
enchant-1.6.0-1.fc13.x86_64
hunspell-1.2.8-17.fc13.x86_64
package hunspell-en is not installed

After manually installing hunspell-en with yum and restarting xchat spell checking is working

Comment 3 Kevin Kofler 2010-06-02 05:35:00 UTC
Well, then blame whoever had the bright idea not to install a spellchecking dictionary by default. While I could theoretically add a Requires: hunspell-en to xchat, IMHO that's entirely the wrong place.

Comment 4 fedora-bugzilla 2010-06-02 05:44:53 UTC
From what I recall I manually installed hunspell and enchant.....I had googled around and found a few forum posts suggesting them..but I was not aware it also needed the hunspell-en

Comment 5 Kevin Kofler 2011-04-12 02:02:41 UTC
*** Bug 695562 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.