Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5982 - installer hangs if package in comps is not present
Summary: installer hangs if package in comps is not present
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-15 14:06 UTC by Nigel Metheringham
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-21 21:20:00 UTC


Attachments (Terms of Use)

Description Nigel Metheringham 1999-10-15 14:06:49 UTC
Whilst making a custom RH based CD a typo was made in
the comps file (package spelt with wrong upper/lower casing)
genhdlist/mkisofs etc was then run.

On install using an upgrade option, and checking the
"customise packages for upgrade" (or similar) option,
the installer hung whilst checking for packages to
upgrade.

[This will only hit people who play silly games with the
installer, but might be worth working round]

Comment 1 Jay Turner 1999-10-21 18:57:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Jay Turner 1999-10-22 19:36:59 UTC
*** Bug 6033 has been marked as a duplicate of this bug. ***

anaconda does not handle misspelled package names very
well.  If a package name is misspelled in RedHat/base/comps,
anaconda dies.

For example, if wu-ftp is specified instead of wu-ftpd,
anaconda dies.  The "old" installer issued an error message
and continued.

Gene

------- Additional Comments From jturner@redhat.com  10/18/99 13:01 -------
This issue has been forwarded to a developer for further action.

Comment 3 Jay Turner 2000-02-21 21:19:59 UTC
This issue is resolved in the latest beta.


Note You need to log in before you can comment on or make changes to this bug.