Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598186 - Mic doesn't work on Acer Aspire One with Pulse Audio
Summary: Mic doesn't work on Acer Aspire One with Pulse Audio
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 17:07 UTC by Alexjan Carraturo
Modified: 2010-06-01 14:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-01 14:00:25 UTC


Attachments (Terms of Use)
Result of running of alsa-info.sh (deleted)
2010-05-31 17:07 UTC, Alexjan Carraturo
no flags Details

Description Alexjan Carraturo 2010-05-31 17:07:23 UTC
Created attachment 418347 [details]
Result of running of alsa-info.sh

The internal microphone does not work on my Acer Aspire One 110 in combination with pulseaudio. Disabling pulseaudio, and setting the microphone (hw) in a random application (eg Skype) works. This problem was already presenting with Fedora 12 (currently use Fedora 13).

Playback still works perfectly with all software, with or without pulseaudio.

I would not uninstall because pulseaudio is a dependency package Bluetooth (important for me).

I saw that the problem is fairly common for Intel HDA made by Realtek (like mine). I read many forums that the problem is common to other distributions such as Ubuntu and openSUSE

I enclose the result of alsa-info.sh

Comment 1 Alexjan Carraturo 2010-06-01 14:00:25 UTC
SOLVED.

Reading here https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/433055


"My Acer Aspire One 110L suddenlty stopped working with the internal mic. I then saw your posts and tried your workaround of setting the L and R microphone channel levels so that they were different (e.g. 89 and 91) and now the internal microphone works!!!
"

There is a better explanation for this problem in italian: http://axjslack.wordpress.com/2010/06/01/acer-aspire-one-fedora-13-e-pulseaudio-adesso-il-microfono-funziona/


Note You need to log in before you can comment on or make changes to this bug.