Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598165 - wine 1.2-rc2 is unusable with wow64 and 32bit EXEs
Summary: wine 1.2-rc2 is unusable with wow64 and 32bit EXEs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 16:07 UTC by Elad Alfassa
Modified: 2010-05-31 17:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 17:11:52 UTC


Attachments (Terms of Use)

Description Elad Alfassa 2010-05-31 16:07:05 UTC
tried to run:
[elad@E-Desktop Bin]$ wine TS3EP01.exe 
Trying to load PE image for unsupported architecture (I386)
Trying to load PE image for unsupported architecture (I386)
wine: Bad EXE format for C:\Program Files\Electronic Arts\The Sims 3 World Adventures\Game\Bin\TS3EP01.exe

list of installed wine packages:

[elad@E-Desktop Bin]$ rpm -qav | grep wine
wine-oss-1.2.0-0.2.rc2.fc13.x86_64
wine-capi-1.2.0-0.2.rc2.fc13.i686
wine-alsa-1.2.0-0.2.rc2.fc13.x86_64
wine-core-1.2.0-0.2.rc2.fc13.i686
wine-ldap-1.2.0-0.2.rc2.fc13.i686
wine-wow-1.2.0-0.2.rc2.fc13.x86_64
wine-common-1.2.0-0.2.rc2.fc13.noarch
wine-alsa-1.2.0-0.2.rc2.fc13.i686
wine-pulseaudio-1.2.0-0.2.rc2.fc13.x86_64
wine-twain-1.2.0-0.2.rc2.fc13.i686
wine-marlett-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-jack-1.2.0-0.2.rc2.fc13.x86_64
wine-oss-1.2.0-0.2.rc2.fc13.i686
wine-pulseaudio-1.2.0-0.2.rc2.fc13.i686
wine-small-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-esd-1.2.0-0.2.rc2.fc13.i686
wine-capi-1.2.0-0.2.rc2.fc13.x86_64
wine-desktop-1.2.0-0.2.rc2.fc13.noarch
wine-openal-1.2.0-0.2.rc2.fc13.x86_64
wine-openal-1.2.0-0.2.rc2.fc13.i686
wine-core-1.2.0-0.2.rc2.fc13.x86_64
wine-ldap-1.2.0-0.2.rc2.fc13.x86_64
wine-cms-1.2.0-0.2.rc2.fc13.i686
wine-system-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-esd-1.2.0-0.2.rc2.fc13.x86_64
wine-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-jack-1.2.0-0.2.rc2.fc13.i686
wine-twain-1.2.0-0.2.rc2.fc13.x86_64
wine-courier-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-nas-1.2.0-0.2.rc2.fc13.i686
wine-cms-1.2.0-0.2.rc2.fc13.x86_64
wine-symbol-fonts-1.2.0-0.2.rc2.fc13.noarch
wine-1.2.0-0.2.rc2.fc13.x86_64
wine-nas-1.2.0-0.2.rc2.fc13.x86_64

Comment 1 Andreas Bierfert 2010-05-31 16:41:56 UTC
I cannot reproduce this here. I have tried with a pre 1.2-rc2 WINEPREFIX and with a clean start. Both putty 64bit and winamp 32bit startup fine if called with just /usr/bin/wine. Could you try with a clean wineprefix and report back.

Comment 2 Elad Alfassa 2010-05-31 17:11:52 UTC
Reinstalling all wine packages solved the problem.


Note You need to log in before you can comment on or make changes to this bug.