Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598141 - [abrt] crash in font-manager-0.4.4-1.fc13: xmlutils.py:371:check_for_fm_req_dir:OSError: [Errno 13] Permission denied
Summary: [abrt] crash in font-manager-0.4.4-1.fc13: xmlutils.py:371:check_for_fm_req_d...
Keywords:
Status: CLOSED DUPLICATE of bug 595853
Alias: None
Product: Fedora
Classification: Fedora
Component: font-manager
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jean-Francois Saucier
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a93bb631
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 14:42 UTC by Gidmantas
Modified: 2010-05-31 15:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 15:08:59 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-31 14:42 UTC, Gidmantas
no flags Details

Description Gidmantas 2010-05-31 14:42:58 UTC
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/font-manager
component: font-manager
executable: /usr/bin/font-manager
kernel: 2.6.33.4-95.fc13.i686.PAE
package: font-manager-0.4.4-1.fc13
reason: xmlutils.py:371:check_for_fm_req_dir:OSError: [Errno 13] Permission denied
release: Fedora release 13 (Goddard)

backtrace
-----
xmlutils.py:371:check_for_fm_req_dir:OSError: [Errno 13] Permission denied

Traceback (most recent call last):
  File "/usr/bin/font-manager", line 87, in <module>
    main()
  File "/usr/bin/font-manager", line 79, in main
    FontManager()
  File "/usr/share/font-manager/main.py", line 78, in __init__
    xmlutils.check_install()
  File "/usr/share/font-manager/xmlutils.py", line 343, in check_install
    check_for_fm_req_dir()
  File "/usr/share/font-manager/xmlutils.py", line 371, in check_for_fm_req_dir
    os.symlink(INSTALL_DIRECTORY, join(USER_FONT_DIR, 'Library'))
OSError: [Errno 13] Permission denied

Local variables in innermost frame:
DIR: '/home/gidmantas/.FontManager/Library'

How to reproduce
-----
1. 
2.
3.

Comment 1 Gidmantas 2010-05-31 14:42:59 UTC
Created attachment 418318 [details]
File: backtrace

Comment 2 Jean-Francois Saucier 2010-05-31 15:08:59 UTC

*** This bug has been marked as a duplicate of bug 595853 ***


Note You need to log in before you can comment on or make changes to this bug.