Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598100 - Cannot do more than ~30 NIC hotplugs
Summary: Cannot do more than ~30 NIC hotplugs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 595780
Blocks: 518407
TreeView+ depends on / blocked
 
Reported: 2010-05-31 12:32 UTC by Paolo Bonzini
Modified: 2011-02-01 09:00 UTC (History)
5 users (show)

Fixed In Version: 1.3.0-1
Doc Type: Bug Fix
Doc Text:
Previously, more than 30 cycles network card hot-plug and hot-unplug caused the guest to reject any further hotplug. With this update, the RHELSCSI driver can sustain repeated cycles of network card hot-plug and hot-unplug.
Clone Of:
Environment:
Last Closed: 2011-02-01 09:00:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0187 normal SHIPPED_LIVE xenpv-win bug fix update 2011-02-01 08:59:58 UTC

Description Paolo Bonzini 2010-05-31 12:32:53 UTC
The drivers cannot do more than approx. 30 hotplugs/hotunplugs.

This is due to some leak in grant table entries.

Comment 3 Florian Nadge 2010-10-18 16:28:21 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, more than 30 cycles network card hot-plug and hot-unplug caused the guest to reject any further hotplug. With this update, the RHELSCSI driver can sustain repeated cycles of network card hot-plug and hot-unplug.

Comment 4 YangGuang 2010-10-20 08:37:50 UTC
Version-Release number of selected component:
xen-3.0.3-117.el5
kernel-xen-2.6.18-228.el5
xenpv-win: 1.2.0
guest: Windows2008r2 HVM

Detailed steps:
1. Edit the vm's config file to install xenpv-win, change the disk
specification like
    disk=['file:...', 'file:/usr/share/xenpv-win/xenpv-win.iso,hdc:cdrom,r',
       'file:/usr/share/xenpv-win/xenpv-win-debug.iso,hdd:cdrom,r']
2. Start the vm with xm create command:
   [host]# xm create $vm-config
3. Open "My Computer", double click "xenpv-win-1.2.0(D:)(CDROM Drive)"
 Or Open CD Drive, then double click xenpv-win.exe
   Then the installer start the installation process, choose "next" all the
way.
4. Execute hot-plug and hot-unplug 500 times.
   [host]# xm pci-attach $domU $dev
   [host]# xm pci-detach $domU $dev
5. using vncviewer to login the guest vm and check.

Detailed result:
1. The guest works well and blue-screen doesn't occur.

I cannot reproduce this bug, so change it to verified.

Comment 5 errata-xmlrpc 2011-02-01 09:00:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0187.html


Note You need to log in before you can comment on or make changes to this bug.