Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598090 - perl-Compress-Raw-Zlib doesn't get upgraded F12 -> F13
Summary: perl-Compress-Raw-Zlib doesn't get upgraded F12 -> F13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Compress-Zlib
Version: 13
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 12:21 UTC by Johan Vromans
Modified: 2010-11-13 10:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-13 10:18:41 UTC


Attachments (Terms of Use)

Description Johan Vromans 2010-05-31 12:21:41 UTC
Description of problem:

When upgrading Fedora 12 to Fedora 13, perl-Compress-Raw-Zlib is not upgraded. F12 provides version 2.024 while F13 has 2.023. As a result, Compress/Raw/Zlib.pm remains in directory /usr/lib/perl5/5.10.0/i386-linux-thread-multi but this directory is not longer part of @INC.

Version-Release number of selected component (if applicable):

perl-Compress-Raw-Zlib-2.024-2.fc12.i686
perl-Compress-Raw-Zlib-2.023-112.fc13.i686

How reproducible:

Always.

Steps to Reproduce:
1. perl -MCompress::Raw::Zlib -e 0
  
Actual results:

Can't locate Compress/Raw/Zlib.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/local/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl .).
BEGIN failed--compilation aborted.

Expected results:

<no output, meaning that everything went okay>

Comment 1 Petr Pisar 2010-05-31 12:57:31 UTC
Somebody forgot to push to stable following packages:

https://admin.fedoraproject.org/updates/perl-Compress-Raw-Zlib-2.024-2.fc13
https://admin.fedoraproject.org/updates/perl-Compress-Raw-Zlib-2.027-1.fc13

Marcela, can you push them? Or is there any reason why not to do that?

Comment 2 Marcela Mašláňová 2010-05-31 14:00:57 UTC
I didn't push them before release of F-13, because there were long email thread about huge updates of F-13 even before release ;-). Pushing now.

Comment 3 Emmanuel Seyman 2010-11-13 10:18:41 UTC
Fixed a long time ago.


Note You need to log in before you can comment on or make changes to this bug.