Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598086 - Iscsi appears as connected while fails to login to dell equallogic iscsi target
Summary: Iscsi appears as connected while fails to login to dell equallogic iscsi target
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 5.5
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Mike Christie
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 12:11 UTC by Moran Goldboim
Modified: 2018-11-26 18:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-04 06:09:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Moran Goldboim 2010-05-31 12:11:57 UTC
Description of problem:
Making volume offline using equallogic admin causing the following event logs on eqaullogic:

ERROR  5/31/10  7:52:57 AM  PS6000  iSCSI login to target '10.16.45.61:3260, iqn.2001-05.com.equallogic:0-8a0906-58eb74a06-c34000000394c024-iscsirecon2' from initiator '10.16.35.104:38956, iqn.1994-05.com.redhat:d5e6ac22112' failed for the following reason:   Requested target not found.   
 ERROR  5/31/10  7:52:57 AM  PS6000  iSCSI login to target '10.16.45.61:3260, iqn.2001-05.com.equallogic:0-8a0906-565b74a06-775000000364c024-iscsirecon' from initiator '10.16.35.104:38955, iqn.1994-05.com.redhat:d5e6ac22112' failed for the following reason:   Requested target not found.    

problem is seen also in var/log/messages:
May 31 08:01:16 east-04 last message repeated 5 times
May 31 08:01:18 east-04 multipathd: sdg: readsector0 checker reports path is down
May 31 08:01:19 east-04 iscsid: conn 0 login rejected: initiator error - target not found (02/03)
May 31 08:01:19 east-04 iscsid: conn 0 login rejected: initiator error - target not found (02/03)
M

Still iscsiadm -m session on the server shows targets are still connected:
[root@east-04 ~]# iscsiadm -m session
tcp: [23] 10.16.45.61:3260,1 iqn.2001-05.com.equallogic:0-8a0906-58eb74a06-c34000000394c024-iscsirecon2
tcp: [24] 10.16.45.61:3260,1 iqn.2001-05.com.equallogic:0-8a0906-565b74a06-775000000364c024-iscsirecon
tcp: [25] 10.16.45.61:3260,1 iqn.2001-05.com.equallogic:0-8a0906-40cb74a06-8dc000000304bfbe-oemr2


 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mike Christie 2011-01-31 07:24:55 UTC
Sorry for the late response on this. I just saw it while searching for something else.

iscsiadm/iscsid does not remove sessions automatically, because many targets reported different error codes for your scenario and we could not determine what targets did what. For the transient case, where it is just offlined temporarily due to something like a maintenance operation, we want the session to get logged back in when the operation is done automatically so apps/multipath can use it.

iscsiadm -m session does not exactly show that we are logged in. If you run iscsiadm -m session -P 1 you will see the session and connection state indicate that the session is not logged in.

You currently have to manually run iscsiadm to kill the sessions.

iscsiadm -m node -T yourtarget -u
or
iscsiadm -m session -r $SESSION_ID -u

We do have a experimental discoveryd option in the rhel 5.6 tools (see the iscsi README for details) that does discovery every X seconds or listens isns async events and would remove the target when offlined, then add it back when it is onlined again.


Note You need to log in before you can comment on or make changes to this bug.