Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 598040 - system stuck at boot at "Starting udev:"
Summary: system stuck at boot at "Starting udev:"
Keywords:
Status: CLOSED DUPLICATE of bug 597232
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 10:01 UTC by Stefan Assmann
Modified: 2010-05-31 11:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 11:05:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stefan Assmann 2010-05-31 10:01:46 UTC
Description of problem:
After updating to todays RHEL6 tree my Lenovo T500 hard hangs during boot.
The problem appears shortly after entering the LUKS password.
The only lines that show up at boot are:
Key slot 0 unlocked.
   Welcome to Red Hat Enterprise Linux Workstation
   Press 'I' to enter interactive startup.
Starting udev: 
! System hangs here for about 1 minute, after that the following messages appear. !
udevd[625]: worker [640] unexpectedly returned with status 0x0100
udevd[625]: worker [640] failed while handling '/devices/pci0000:00/0000:00:1b.0'
                                                              [OK]

Not sure this is really udev's fault...

How reproducible:
always

Comment 2 Stefan Assmann 2010-05-31 10:27:42 UTC
added udevdebug=1 to the kernel commandline.
After that udev generates tons of debug statements and hasn't finished even after 20 minutes. This doesn't seem to help.

Comment 3 Phil Knirsch 2010-05-31 11:05:18 UTC
See bug #597232. This is a problem of the new module-init-tools. Reverting to an older version fixes it.

Closing as dup.

Thanks & regards, Phil

*** This bug has been marked as a duplicate of bug 597232 ***


Note You need to log in before you can comment on or make changes to this bug.