Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5980 - tcsh does not work correctly with patterns
Summary: tcsh does not work correctly with patterns
Keywords:
Status: CLOSED DUPLICATE of bug 6000
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL: tcsh does not work correctly with pat...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-15 10:47 UTC by zut
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-08 16:09:44 UTC


Attachments (Terms of Use)

Description zut 1999-10-15 10:47:04 UTC
Found a bug in tcsh:

Example: (typed in a running tcsh)
pc-9:~ mkdir t
pc-9:~ cd t
pc-9:~/t touch A B c
pc-9:~/t echo [A-Z]*
A B c
pc-9:~/t sh
[zut@pc-9 t]$ echo [A-Z]*
A B
[zut@pc-9 t]$

sh parses the patterns correctly, tcsh works wrong !

Comment 1 ilh 1999-10-15 20:31:59 UTC
I think this is a serious bug having to due with glibc and locale.
With LC_ALL=en_US, this bug always happens for me in 6.1.  With LC_ALL
undefined and LC_COLLATE=C, it works fine.

This bug is going to break a lot of scripts!

Comment 2 Bill Nottingham 1999-11-08 16:09:59 UTC
*** This bug has been marked as a duplicate of 6000 ***


Note You need to log in before you can comment on or make changes to this bug.