Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597983 - Continually suspending guest to memory caused migration failed
Summary: Continually suspending guest to memory caused migration failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: beta
: 6.1
Assignee: Juan Quintela
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 07:30 UTC by Amos Kong
Modified: 2015-05-25 00:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-21 03:44:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Amos Kong 2010-05-31 07:30:46 UTC
Description of problem:
I try to execute s3 in guest, and do migration at the same time. When migration completed, check the migration status by monitor command.

guest1-monitor) migrate tcp:0:4444
guest1 -monitor) info migrate
Migration status: failed

_Actually_, guest has been migrated to dest VM.

Version-Release number of selected component (if applicable):

host kernel: 2.6.32-25.el6.x86_64
# rpm -qa |grep qemu
qemu-img-0.12.1.2-2.62.el6.x86_64
qemu-kvm-0.12.1.2-2.62.el6.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.62.el6.x86_64
gpxe-roms-qemu-0.9.7-6.3.el6.noarch
qemu-kvm-tools-0.12.1.2-2.62.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot up src and dest VMs.
2. continually execute s3 in guest
# while true; do echo "mem" > /sys/power/state; done
3. try to do migration
guest1-qemu) migrate tcp:0:4444
guest1-qemu) info migrate
  
Actual results:
migration completed successfully

Expected results:
migrate failed

Additional info:

1. Command line:
guest1) qemu-kvm -name 'vm1' -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64.qcow2,if=ide,cache=none,boot=on -net nic,vlan=0,model=e1000,macaddr=02:A9:7C:6C:3b:4d -net tap,vlan=0,ifname=e1000_1,downscript=no -m 512 -smp 1 -soundhw ac97  -vnc :0 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -serial unix:/tmp/serial-20100528-180850-IsP5,server,nowait -snapshot

guest2) qemu-kvm -name 'vm2' -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-6.0-64.qcow2,if=ide,cache=none,boot=on -net nic,vlan=0,model=e1000,macaddr=02:A9:7C:6C:3b:4d -net tap,vlan=0,ifname=e1000_2,downscript=no -m 512 -smp 1 -soundhw ac97  -vnc :2 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -serial unix:/tmp/serial-20100528-180850-IsP52,server,nowait -snapshot -incoming tcp:0:4444

Comment 2 RHEL Product and Program Management 2010-06-07 15:58:18 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Dor Laor 2010-06-08 13:24:14 UTC
Did s3 always work regardless of migration? What's the guest type?

Comment 4 Amos Kong 2010-06-09 15:31:49 UTC
s3 works well regardless of migration.
rhel55 guest, kernel: 2.6.18-201.el5.x86_64

Comment 6 Alex Williamson 2011-01-19 21:52:13 UTC
Please retest on latest bits, I'm unable to reproduce on:

qemu-kvm-0.12.1.2-2.129.el6.x86_64
kernel-2.6.32-94.el6.x86_64

With guest in S3 loop, migration completes and 'info migrate' on the migration source reports the migration as completed successfully.

Comment 7 Amos Kong 2011-01-21 03:16:40 UTC
(In reply to comment #6)
> Please retest on latest bits, I'm unable to reproduce on:
> 
> qemu-kvm-0.12.1.2-2.129.el6.x86_64
> kernel-2.6.32-94.el6.x86_64
> 
> With guest in S3 loop, migration completes and 'info migrate' on the migration
> source reports the migration as completed successfully.

I also could not reproduce this bug.
. qemu-kvm-0.12.1.2-2.129.el6.x86_64 & 2.6.32-94.el6.x86_64 [success]
. qemu-kvm-0.12.1.2-2.129.el6.x86_64 & 2.6.32-99.el6.x86_64 [success]

Comment 8 Alex Williamson 2011-01-21 03:44:44 UTC
This seems to be fixed in qemu-kvm-0.12.1.2-2.129.el6.x86_64, if not earlier.


Note You need to log in before you can comment on or make changes to this bug.