Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597982 - version::Internals should be packaged in perl-version subpackage, not main perl package
Summary: version::Internals should be packaged in perl-version subpackage, not main pe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Marcela Mašláňová
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On: 549306
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 07:30 UTC by Marcela Mašláňová
Modified: 2010-11-11 14:54 UTC (History)
11 users (show)

Fixed In Version: perl-5.10.1-110.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 549306
Environment:
Last Closed: 2010-11-11 14:54:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marcela Mašláňová 2010-05-31 07:30:19 UTC
+++ This bug was initially created as a clone of Bug #549306 +++

Description of problem:
Conflict trying to install local perl-version package, due to conflict between /usr/share/man/man3/version::Internals.3pm.gz in local perl-version package and main Fedora perl package.

/usr/share/perl5/version/Internals.pod should also be in the perl-version subpackage.


Version-Release number of selected component (if applicable):
perl-5.10.1-106.fc13

--- Additional comment from mmaslano@redhat.com on 2009-12-22 03:01:20 EST ---

Thank you for your report, this will be fixed in -108

--- Additional comment from paul@city-fan.org on 2009-12-27 17:55:34 EST ---

Not fixed in -109, which still has /usr/share/man/man3/version::Internals.3pm.gz
and /usr/share/perl5/version/Internals.pod in the main perl package.

--- Additional comment from mmaslano@redhat.com on 2010-01-04 05:58:41 EST ---

It was fixed only locally, I'll push it into next update.

--- Additional comment from paul@city-fan.org on 2010-05-28 12:08:37 EDT ---

This issue is present in the RHEL-6 Beta release of perl too - perl-4:5.10.1-106.el6; can it be fixed there as well please?

Comment 2 RHEL Product and Program Management 2010-06-02 08:06:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Petr Šplíchal 2010-09-10 17:38:18 UTC
Verified that version::Internals is now contained in the
perl-version package, both perldoc & man page work as expected:

# rpm -q perl perl-version
perl-5.10.1-115.el6.x86_64
perl-version-0.77-115.el6.x86_64

# rpm -ql perl | grep -i version
/usr/lib64/perl5/auto/Storable/BIN_VERSION_NV.al
/usr/lib64/perl5/auto/Storable/BIN_WRITE_VERSION_NV.al
/usr/share/perl5/unicore/version

# rpm -ql perl-version
/usr/share/man/man3/version.3pm.gz
/usr/share/man/man3/version::Internals.3pm.gz
/usr/share/perl5/version
/usr/share/perl5/version.pm
/usr/share/perl5/version.pod
/usr/share/perl5/version/Internals.pod

# man version::Internals

version::Internals(3pm)Perl Programmers Reference Guideversion::Internals(3pm)

NAME
       version::Internal - Perl extension for Version Objects

DESCRIPTION
       Overloaded version objects for all modern versions of
       Perl.  This documents the internal data representation and
       underlying code for version.pm.  See version.pod for daily
       usage.  This document is only useful for users writing a
       subclass of version.pm or interested in the gory details.

What IS a version
       For the purposes of this module, a version "number" is a
       sequence of positive integer values separated by one or
       more decimal points and optionally a single underscore.
       This corresponds to what Perl itself uses for a version,
       as well as extending the "version as number" that is
       discussed in the various editions of the Camel book.

Comment 7 releng-rhel@redhat.com 2010-11-11 14:54:01 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.