Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597824 - After F12 -> F13 update /lib/udev/rules.d/85-usbmuxd.rules is broken
Summary: After F12 -> F13 update /lib/udev/rules.d/85-usbmuxd.rules is broken
Keywords:
Status: CLOSED DUPLICATE of bug 593494
Alias: None
Product: Fedora
Classification: Fedora
Component: usbmuxd
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 16:48 UTC by Jean-frederic Clere
Modified: 2010-05-31 09:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 09:03:30 UTC


Attachments (Terms of Use)

Description Jean-frederic Clere 2010-05-30 16:48:33 UTC
After updating to F13 tethering via USB stops working. It seems it is due to user name problem.

In /lib/udev/rules.d/85-usbmuxd.rules
# Forces iPhone 1.0, 3G, 3GS, iPodTouch 1/2 and iPad to USB configuration 3 and run usbmuxd
ACTION=="add", SUBSYSTEM=="usb", OWNER="usbmuxd", ATTR{idVendor}=="05ac", ATTR{idProduct}=="129[0-9a]", ENV{USBMUX_SUPPORTED}="1", ATTR{bConfigurationValue}!="$attr{bNumConfigurations}", ATTR{bConfigurationValue}="$attr{bNumConfigurations}", RUN+="/usr/sbin/usbmuxd -u -U usbmux"

In /etc/passwd:
usbmuxd:x:113:113:usbmuxd user:/:/sbin/nologin

Comment 1 Peter Robinson 2010-05-31 09:03:30 UTC
Actually was a bug in the 1.0.3 -> 1.0.4 upgrade on all Fedora releases.

Fixed in https://admin.fedoraproject.org/updates/usbmuxd-1.0.4-2.fc13

Please check existing bug reports before filing new ones.

*** This bug has been marked as a duplicate of bug 593494 ***


Note You need to log in before you can comment on or make changes to this bug.