Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597820 - [abrt] crash in openoffice.org-writer-1:3.2.0-12.17.fc13: SwRTFWriter::OutBookmarks: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in openoffice.org-writer-1:3.2.0-12.17.fc13: SwRTFWriter::OutBoo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:14993c197cbf63c4a6a4572f300...
: 600928 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 16:28 UTC by Frank
Modified: 2010-06-08 13:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-08 13:26:29 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-30 16:28 UTC, Frank
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 109284 None None None Never

Description Frank 2010-05-30 16:28:51 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///home/ptest/Desktop/FLbiosketchDimensions2010.rtf
comment: just typing, writer crashed out of the blue
component: openoffice.org
crash_function: SwRTFWriter::OutBookmarks
executable: /usr/lib64/openoffice.org3/program/swriter.bin
global_uuid: 14993c197cbf63c4a6a4572f300992218e97fec7
kernel: 2.6.33.4-95.fc13.x86_64
package: openoffice.org-writer-1:3.2.0-12.17.fc13
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
unknown

Comment 1 Frank 2010-05-30 16:28:55 UTC
Created attachment 418058 [details]
File: backtrace

Comment 2 David Tardon 2010-05-31 05:43:22 UTC
Ah, pAsBookmark may be NULL here...

Comment 3 David Tardon 2010-05-31 05:50:52 UTC
fix committed, will be in >=3.2.0-12.24

Comment 4 David Tardon 2010-06-06 18:45:26 UTC
*** Bug 600928 has been marked as a duplicate of this bug. ***

Comment 5 Caolan McNamara 2010-06-08 13:26:29 UTC
should be good in 3.2.0-12.24.fc13


Note You need to log in before you can comment on or make changes to this bug.