Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597747 - Ballbuster gameplay is not smooth
Summary: Ballbuster gameplay is not smooth
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 10:53 UTC by Frank Murphy
Modified: 2010-06-01 07:26 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-01 07:26:18 UTC


Attachments (Terms of Use)

Description Frank Murphy 2010-05-30 10:53:24 UTC
Description of problem: Jerky ballbuster Game


Version-Release number of selected component (if applicable):
kernel-2.6.34-11.fc14.x86_64
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.fc13.x86_64
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1)


How reproducible:
Always

Steps to Reproduce:
1. install ballbuster
.
  
Actual results: http://en.zimagez.com/zimage/screenshot-300510-113620.php


Expected results: Smooth gameplay


Additional info: Works fine on F13 with Intel graphics:
and the following scratch kernel:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2217307

Comment 1 Jon Stanley 2010-05-30 17:00:41 UTC
Since the same kernel works on F13 (all I did was take the SRPM and do a scratch build, I didn't even disable debugging like Kyle did in his build), I would say that this is unlikely to be a kernel issue, but rather something else in the stack. For now, I'm moving this to nouveau, but that might not be the right place either.

Comment 2 Ben Skeggs 2010-05-30 23:38:31 UTC
ballbuster uses OpenGL, and won't be smooth without a hardware 3D driver.  How's things if you install mesa-dri-drivers-experimental?

Comment 3 Frank Murphy 2010-05-31 09:26:07 UTC
90% improvement

Comment 4 Ben Skeggs 2010-05-31 23:30:55 UTC
So, bug closed?

Comment 5 Frank Murphy 2010-06-01 07:08:54 UTC
(In reply to comment #4)
> So, bug closed?    

Yes, close her up.
It can only get better.

Comment 6 Ben Skeggs 2010-06-01 07:26:18 UTC
Thanks :)


Note You need to log in before you can comment on or make changes to this bug.