Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597688 - Pointless /etc/krb5.conf.rpmnew file created
Summary: Pointless /etc/krb5.conf.rpmnew file created
Keywords:
Status: CLOSED DUPLICATE of bug 597689
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 04:51 UTC by D. Wagner
Modified: 2010-06-02 14:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 14:53:17 UTC


Attachments (Terms of Use)
full log from "strace -e rename rpm --oldpackage -Uvv krb5-libs-1.7.1-10.*" (deleted)
2010-06-01 18:26 UTC, Nalin Dahyabhai
no flags Details

Description D. Wagner 2010-05-30 04:51:41 UTC
Description of problem:

I upgraded from F12 to F13.  After the upgrade, I have a new file /etc/krb5.conf.rpmnew which is an identical duplicate of /etc/krb5.conf.

# ls -l /etc/krb5*
-rw-r--r--. 1 root root 449 Feb 16 14:38 /etc/krb5.conf
-rw-r--r--. 1 root root 449 Feb 16 14:38 /etc/krb5.conf.rpmnew
# sha1sum /etc/krb5*
e4dc65f41d4ba63532599447cc315e5e4bc9c5c1  /etc/krb5.conf
e4dc65f41d4ba63532599447cc315e5e4bc9c5c1  /etc/krb5.conf.rpmnew

There is no need to create a .rpmnew file in this case.  I suspect this is a RPM packaging error, perhaps related to multilib/multiarch support.

Version-Release number of selected component (if applicable):

# rpm -q -f /etc/krb5.conf
krb5-libs-1.7.1-10.fc13.x86_64
krb5-libs-1.7.1-10.fc13.i686

Comment 1 Nalin Dahyabhai 2010-06-01 18:24:59 UTC
The only thing RPM should be checking here is the permissions (vaguely -- it uses them to check if the type of the file has changed, for example from a regular file to a symlink or whatnot) and the checksum of the contents of the file when compared to what's already on the disk.

The default F-13 contents are different from those in F-12, so that would explain the presence of a .rpmnew file, but that doesn't explain krb5.conf.

Updating the packages manually with rpm with -vv and asking strace to show rename() calls turns up:
  D: fini      100644  1 (   0,   0)       449 /etc/krb5.conf;4c0547b4 
  rename("/etc/krb5.conf;4c0547b4", "/etc/krb5.conf") = 0
  D: fini      100644  1 (   0,   0)       449 /etc/krb5.conf;4c0547b4 altname
  rename("/etc/krb5.conf;4c0547b4", "/etc/krb5.conf.rpmnew") = 0
  warning: /etc/krb5.conf created as /etc/krb5.conf.rpmnew
  D: fini      100644  1 (   0,   0)       449 /etc/krb5.conf skip
  D: fini      100644  1 (   0,   0)       449 /etc/krb5.conf skip
which suggests that the 64-bit package's krb5.conf actually overwrites the one that's on the system (the files that go in right after are 64-bit, I'll attach the full log), and the i686 package's is treated as a conflict, so it gets created with the .rpmnew extension.

Comment 2 Nalin Dahyabhai 2010-06-01 18:26:41 UTC
Created attachment 418769 [details]
full log from "strace -e rename rpm --oldpackage -Uvv krb5-libs-1.7.1-10.*"

Comment 3 Nalin Dahyabhai 2010-06-01 18:27:31 UTC
Ccing the RPM maintainer.

Panu, can you help me to understand what I'm doing wrong with the packaging here?

Comment 4 Panu Matilainen 2010-06-02 05:11:53 UTC
Looks the same as bug 597689: an unnecessary backup of config files gets created on multilib upgrade when the default contents change. Feel free to close this as a dupe, rpm failing to deal with the multilib case correctly here is hardly a packaging bug.

Comment 5 Nalin Dahyabhai 2010-06-02 14:53:17 UTC
Okay, will do.  Thanks!

*** This bug has been marked as a duplicate of bug 597689 ***


Note You need to log in before you can comment on or make changes to this bug.