Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597682 - AttributeError: 'NoneType' object has no attribute 'format'
Summary: AttributeError: 'NoneType' object has no attribute 'format'
Keywords:
Status: CLOSED DUPLICATE of bug 573492
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:f0c7cd97681546c86...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 04:23 UTC by Chris Miller
Modified: 2010-05-30 05:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-30 05:11:13 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2010-05-30 04:23 UTC, Chris Miller
no flags Details

Description Chris Miller 2010-05-30 04:23:48 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 839, in mirrorFailureCB
    dev.format.mountpoint = self.tree
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 297, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 402, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 408, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 810, in _getFile
    size=size
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 986, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1201, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1374, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1399, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1409, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1417, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1227, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 223, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 279, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 564, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 527, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1220, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1247, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1221, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/yuminstall.py", line 1177, in doBackendSetup
    self.doSackSetup(anaconda)
  File "/usr/lib/anaconda/backend.py", line 282, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 228, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1346, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1522, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1532, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1263, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1223, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'format'

Comment 1 Chris Miller 2010-05-30 04:23:53 UTC
Created attachment 417979 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2010-05-30 05:11:13 UTC

*** This bug has been marked as a duplicate of bug 573492 ***


Note You need to log in before you can comment on or make changes to this bug.