Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597449 - [abrt] crash in anki-0.9.9.8.6-2.fc13: main.py:1013:save:AttributeError: 'NoneType' object has no attribute 'modifiedSinceSave'
Summary: [abrt] crash in anki-0.9.9.8.6-2.fc13: main.py:1013:save:AttributeError: 'Non...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anki
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:decc0a0c
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-29 00:29 UTC by behzadnouri
Modified: 2010-06-01 20:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-01 20:30:39 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-29 00:29 UTC, behzadnouri
no flags Details

Description behzadnouri 2010-05-29 00:29:00 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/anki
component: anki
executable: /usr/bin/anki
kernel: 2.6.33.4-95.fc13.x86_64
package: anki-0.9.9.8.6-2.fc13
reason: main.py:1013:save:AttributeError: 'NoneType' object has no attribute 'modifiedSinceSave'
release: Fedora release 13 (Goddard)

backtrace
-----
main.py:1013:save:AttributeError: 'NoneType' object has no attribute 'modifiedSinceSave'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ankiqt/ui/main.py", line 919, in onOpenOnline
    if not self.saveAndClose(hideWelcome=True): return
  File "/usr/lib/python2.6/site-packages/ankiqt/ui/main.py", line 857, in saveAndClose
    self.save()
  File "/usr/lib/python2.6/site-packages/ankiqt/ui/main.py", line 1013, in save
    if not self.deck.modifiedSinceSave():
AttributeError: 'NoneType' object has no attribute 'modifiedSinceSave'

Local variables in innermost frame:
self: <ankiqt.ui.main.AnkiQt object at 0x2284958>
required: False

Comment 1 behzadnouri 2010-05-29 00:29:02 UTC
Created attachment 417779 [details]
File: backtrace

Comment 2 Christian Krause 2010-06-01 20:00:05 UTC
Thank you very much for the bug report. In order to work on this problem we'll need the following information:

1. Can you reproduce the problem? If yes, please provide exact steps how to reproduce.

2. Does it happen with a specific deck of cards? If yes, can you attach this deck to this bug report or make the deck publically available?

Comment 3 behzadnouri 2010-06-01 20:12:23 UTC
I cannot reproduce the problem. It happened when I reinstalled my OS, and wanted to download the decks by sync over net. And it crashed. I retried it and everything worked fine.

Everything works fine afterwards

Thanks,

Comment 4 Christian Krause 2010-06-01 20:30:39 UTC
Thanks for the prompt reply!

I have talked with the upstream developer about this issue. He has inspected the code and it looks like that this problem should not happen at all... ;-)

So unfortunately nothing an be done unless there would be a way to reproduce it...

I'll close this bug report as CANTFIX for now. If you see the problem again (or anybody else), we can re-open it.


Note You need to log in before you can comment on or make changes to this bug.