Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597421 - Gnome-panel fails to display on start-up
Summary: Gnome-panel fails to display on start-up
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 620295
TreeView+ depends on / blocked
 
Reported: 2010-05-28 21:35 UTC by pagina_secunda
Modified: 2011-06-27 16:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-27 16:57:16 UTC


Attachments (Terms of Use)
.xsession-errors fille (deleted)
2010-07-28 17:37 UTC, Peter H. Jones
no flags Details

Description pagina_secunda 2010-05-28 21:35:30 UTC
Description of problem: Whenever I log in, the gnome-panels are missing.  I have to open a terminal from my desktop, find the process, and give a kill command to the PID for gnome-panel.  Upon killing it, the gnome-panel then loads itself properly.


Version-Release number of selected component (if applicable):
gnome-panel-2.30.0-1.fc13.x86_64

How reproducible:
Consistent

Steps to Reproduce:
1. Log in
2.
3.
  
Actual results:
Everything behaves normally except the gnome-panel fails to display.

Expected results:
Gnome-panel is displayed.

Additional info:
I began noticing that it the panel failed to load after installing accountsdialog and accountsservice.  Also, when the panel comes back, the "Weather Report" applet fails to load.  I have no idea if that is relevant to the problem.

Comment 1 Peter H. Jones 2010-07-28 13:45:24 UTC
I have gnome-panel-2.30.0-4.fc13.i686 . I see a similar problem intermittently (every couple of days, or so, with a dozen starts each day. In my case, the menus at the top and bottom of the screen never appear. The icons in the desktop behave normally, but I can't launch any apps without the menus.

I can use CTRL-ALT-DEL, or jab the Power button to get a shutdown menu. If I select Shutdown, I see a panel saying "Panel is not responding". If I select "Shutdown Anyway", the system shuts down, and the next start is usually normal. This morning, however, I had to go through the shutdown/restart twice.

Tried Google search for "gnome-panel tracing", and found a more severe case in Ubunto at https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/482690 . Several gdb strategies and workarounds are mentioned there, but I haven't tried any as yet.

I do have the weather report app installed. Usually, I have no trouble with it.

Comment 2 Peter H. Jones 2010-07-28 17:37:57 UTC
Created attachment 435092 [details]
.xsession-errors fille

Comment 3 Peter H. Jones 2010-07-28 17:46:45 UTC
The icons at the top of the screen were displayed after startup, but did not respond to the mouse. The desktop did function; I was able to "Clean Up by Name", for instance.

Based on my reading above, I tried CTRL-F2, and found myself in a login screen. I logged in, and tried "ps -flu <username>" | grep gnome, and found a gnome-panel running. I noted its PID, and typed "kill -USR1 <pid>". Using CTRL-F1 to return to the full-screen session, I found it to be operationg normally! (Just a stroke of intuition; I'd like to find documentation with a proper unfreezing procedure.) Searching for "gnome-panel documentation" led me to gnome-panel source code, but not a man page.

Comment 4 Bug Zapper 2011-06-02 13:00:11 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Bug Zapper 2011-06-27 16:57:16 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.