Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597411 - [abrt] crash in galeon-2.0.7-27.fc13: Process /usr/bin/galeon was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in galeon-2.0.7-27.fc13: Process /usr/bin/galeon was killed by s...
Keywords:
Status: CLOSED DUPLICATE of bug 577103
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Yanko Kaneti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f1b8fc70b1bb7c1f857937073e6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 20:58 UTC by Christian Jose
Modified: 2010-05-30 19:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-30 19:46:35 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-28 20:58 UTC, Christian Jose
no flags Details

Description Christian Jose 2010-05-28 20:58:42 UTC
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: galeon
comment: Launch Galeon
component: galeon
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/bin/galeon
global_uuid: f1b8fc70b1bb7c1f857937073e65497cf71a3b89
kernel: 2.6.33.4-95.fc13.i686.PAE
package: galeon-2.0.7-27.fc13
rating: 4
reason: Process /usr/bin/galeon was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Launch Galeon
2. Select "Discard Previous Session"
3.

Comment 1 Christian Jose 2010-05-28 20:58:44 UTC
Created attachment 417745 [details]
File: backtrace

Comment 2 Yanko Kaneti 2010-05-29 08:06:08 UTC
This looks like bug 577103
can you try removing ~/.galeon/mozilla/galeon/compreg.dat to work around the
crash?

Comment 3 Christian Jose 2010-05-30 14:54:59 UTC
Thank you for the help.

Removing ~/.galeon/mozilla/galeon/compreg.dat resolves the issue, although you do of course lose a bunch of configuration settings.

It's possible that the problem had something to do with using preupgrade to update from Fedora 12 to Fedora13. This was the first time I had tried to use Galeon since the upgrade and it was working fine previously.

Comment 4 Yanko Kaneti 2010-05-30 19:46:35 UTC
Thanks for the feedback.

*** This bug has been marked as a duplicate of bug 577103 ***


Note You need to log in before you can comment on or make changes to this bug.