Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5974 - NIC initialization during kernel loading
Summary: NIC initialization during kernel loading
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-15 03:36 UTC by eschambe
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-06 02:20:59 UTC


Attachments (Terms of Use)

Description eschambe 1999-10-15 03:36:29 UTC
While the kernel loads there is a line:

device eth0 delayed initialization   [Failed]

This creates a lack of network connection.  The module
loaded is the 3c59x for a 3com NIC.
The installation was an upgrade from existing install(6.0)
in which the NIC loaded properly.  Might be caused by an
autodetecting/probing of the device to specify the line
passed to the kernel?

Comment 1 Bill Nottingham 1999-10-15 15:39:59 UTC
What does /etc/conf.modules look like?

------- Additional Comments From   10/15/99 16:58 -------
conf.modules:
alias eth0 3c59x
alias parport_lowlevel parport_pc
pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start
options 3c59x irq=11

Comment 2 Bill Nottingham 1999-10-19 18:14:59 UTC
What happens if you do 'modprobe 3c59x' from the command line?

------- Additional Comments From   10/19/99 17:31 -------
returns back with "can't locate module 3c59x"
Is this module missing from the kernel that is installed with 6.1, I
need to check the kernel version.

Comment 3 Cristian Gafton 2000-01-04 22:27:59 UTC
Assigned to dledford

Comment 4 Bill Nottingham 2000-02-06 02:20:59 UTC
The 3c59x module is included with 6.1.

Comment 5 Alan Cox 2000-08-08 13:43:32 UTC
This sounds like a corrupted install. Closing it in the absence of other info




Note You need to log in before you can comment on or make changes to this bug.