Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597339 - WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x202/0x30e()
Summary: WARNING: at fs/fs-writeback.c:597 writeback_inodes_wb+0x202/0x30e()
Keywords:
Status: CLOSED DUPLICATE of bug 593669
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 17:18 UTC by acount closed by user
Modified: 2010-05-31 15:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-31 15:24:15 UTC


Attachments (Terms of Use)
dmesg (deleted)
2010-05-28 17:19 UTC, acount closed by user
no flags Details
lspci (deleted)
2010-05-28 17:19 UTC, acount closed by user
no flags Details

Description acount closed by user 2010-05-28 17:18:42 UTC
doing anything special.

Comment 1 acount closed by user 2010-05-28 17:19:36 UTC
Created attachment 417689 [details]
dmesg

Comment 2 acount closed by user 2010-05-28 17:19:57 UTC
Created attachment 417690 [details]
lspci

Comment 3 acount closed by user 2010-05-28 17:22:34 UTC
(In reply to comment #0)

> doing anything special.    

NOT doing anything special.

Comment 4 Mace Moneta 2010-05-29 15:09:29 UTC
Looks to be addressed by:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=7c8a3554c683f512dbcee26faedb42e4c05f12fa

author	Jens Axboe <jens.axboe@oracle.com>	
Tue, 18 May 2010 12:29:29 +0000 (14:29 +0200)
committer	Jens Axboe <jens.axboe@oracle.com>	
Fri, 21 May 2010 18:00:25 +0000 (20:00 +0200)
commit	7c8a3554c683f512dbcee26faedb42e4c05f12fa
tree	ece0d1b79ccc1f596b0ccd0217b584c27a3ff414	tree | snapshot
parent	2db4e42eaceabec42f738f3895300632cd375e67	commit | diff
writeback: ensure that WB_SYNC_NONE writeback with sb pinned is sync

Even if the writeout itself isn't a data integrity operation, we need
to ensure that the caller doesn't drop the sb umount sem before we
have actually done the writeback.

This is a fixup for commit e913fc82.

Signed-off-by: Jens Axboe <jens.axboe@oracle.com>

Comment 5 Stu Tomlinson 2010-05-31 15:24:15 UTC

*** This bug has been marked as a duplicate of bug 593669 ***


Note You need to log in before you can comment on or make changes to this bug.