Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597258 - Update cluster.ng
Summary: Update cluster.ng
Keywords:
Status: CLOSED DUPLICATE of bug 520866
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster
Version: 5.6
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 597253
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 14:11 UTC by Marek Grac
Modified: 2010-08-09 16:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 597253
Environment:
Last Closed: 2010-08-09 16:00:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marek Grac 2010-05-28 14:11:53 UTC
In RHEL5 there will be probably same issue also with

login_timeout, shell_timeout, power_timeout

(list of all options is available in fence-agents lib/fencing.py)


+++ This bug was initially created as a clone of Bug #597253 +++

You wrote:
> While the actual fix appears to work fine, there is a problem with
validating the cluster.conf with the newly added power_wait atttibute:

Indeed, the schema used in validation is part of the system-config-cluster
package which was not refreshed as part of the hotfix. To have it recognise
the new attribute, it would need a patch similar to the following:

--- ./src/misc/cluster.ng.orig 2010-03-10 16:02:40.899864461 +0100
+++ ./src/misc/cluster.ng 2010-03-10 16:08:29.717864438 +0100
@@ -98,6 +98,9 @@
         <optional>
          <attribute name="force"/>
         </optional>
+        <optional>
+         <attribute name="power_wait"/>
+        </optional>
        </group>
        <!-- GNBD -->
        <group>

Comment 1 Lon Hohberger 2010-08-09 16:00:45 UTC

*** This bug has been marked as a duplicate of bug 520866 ***


Note You need to log in before you can comment on or make changes to this bug.