Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597252 - [PATCH] Intel i915 drm driver doesnot correctly enumerates output
Summary: [PATCH] Intel i915 drm driver doesnot correctly enumerates output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 14
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 13:59 UTC by vadim
Modified: 2010-10-07 15:43 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-07 09:17:15 UTC


Attachments (Terms of Use)
patch to fix (deleted)
2010-05-28 13:59 UTC, vadim
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Linux Kernel 16068 None None None Never

Description vadim 2010-05-28 13:59:37 UTC
Created attachment 417616 [details]
patch to fix

i915 cannot correctly attach svdo->vga converter.
the problem is in counting outputs of same type.
svdo output connector first created, but then output type is modified. But
output type modification should follow "devices of that type" counter
modification

I submitted patch to kernel, but I constantly use Fedora, and I have to use fedora 10. Now I can upgrade to FC13 with rawhide kernel. Kernel very close to fox Intel SDVO->VGA, I hope patch will be on rawhide very soon

https://bugzilla.kernel.org/show_bug.cgi?id=16068

Comment 1 Kevin Fenzi 2010-07-03 19:07:41 UTC
Moving this over to xorg-x11-drv-intel for review and further comment.

Comment 2 Bug Zapper 2010-07-30 11:44:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Adam Williamson 2010-10-06 22:10:58 UTC
Looks like upstream's been more conscientious about this than we have - Jesse wrote in July that it should be fixed upstream. Reporter, has this fix made it downstream to whichever Fedora you're on now?

Comment 4 vadim 2010-10-07 09:17:15 UTC
This bug is fixed for kernels >= 2.6.35. Tested on 2.6.35.2, 2.6.35.3, 2.6.35.7.

Comment 5 Adam Williamson 2010-10-07 15:43:28 UTC
OK. We're on 2.6.35 for F14 so that's probably good enough. thanks for testing!


Note You need to log in before you can comment on or make changes to this bug.